Bug 1279314 - [Tier]: After volume restart, unable to stop the started detach tier
[Tier]: After volume restart, unable to stop the started detach tier
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Dan Lambright
nchilaka
: ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-11-09 02:17 EST by Byreddy
Modified: 2016-09-17 11:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:53:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2015-11-09 02:17:52 EST
Description of problem:
=======================
After volume restart the tier detach  stop failing with error message "volume detach-tier stop: failed: Detach-tiernot started" and detach-tier commit is removing the tier.

Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.5-5


How reproducible:
=================
100%


Steps to Reproduce:
===================
1.Have a two node cluster
2.Create a replica (1*2) volume using two nodes and start it.
3.Attach tier of type Distributes (1*1) 
4.Restart the volume // gluster volume <vol_name> start force
5.Stop the detach tier  // it will fail
6.Do detach tier commit // it will pass

Actual results:
===============
After volume restart, unable to stop the started detach tier

Expected results:
================
Should be able to stop the detach tier even after volume restart.


Additional info:
Comment 3 Byreddy 2015-11-18 03:55:05 EST
Small correction in reproducing steps:
======================================

1.Have a two node cluster
2.Create a replica (1*2) volume using two nodes and start it.
3.Attach tier of type Distributes (1*1) 

4.Start the detach tier    ****missed this step previously*****

5.Restart the volume // gluster volume <vol_name> start force
6.Stop the detach tier  // it will fail
7.Do detach tier commit // it will pass
Comment 6 hari gowtham 2016-01-19 07:58:26 EST
I will try to reproduce it. and update the bug before 20th jan evening
Comment 7 hari gowtham 2016-01-22 02:29:48 EST
It works on the upstream, master.
Comment 9 hari gowtham 2016-01-22 06:43:18 EST
The patch set to the upstream master to fix this is:
http://review.gluster.org/#/c/12833/

the patch for 3.7.6 is:
http://review.gluster.org/#/c/12921/
Comment 10 hari gowtham 2016-01-27 01:31:39 EST
The downstream patch is:
https://code.engineering.redhat.com/gerrit/#/c/63464/
Comment 11 Bhaskarakiran 2016-01-28 06:35:15 EST
From the mail, the conversion:

The bug 1279314 was marked as known issue. When we were trying to document that, we learned it was fixed and then removed from the tracker.
The RCA for both the bugs turned out to be same and hence fixed with 1284387. Please note the patch in 2 was merged with 1284387, which is fully acked.

Regards,
Vivek
Comment 14 Bhaskarakiran 2016-01-31 11:23:15 EST
Marking this as verified.
Comment 16 errata-xmlrpc 2016-03-01 00:53:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.