Bug 1279329 - RHEV-M page crash after setup root password
RHEV-M page crash after setup root password
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: legacy-ovirt-node-plugin-vdsm (Show other bugs)
3.6
Unspecified Unspecified
urgent Severity urgent (vote)
: ovirt-3.6.0-rc3
: 3.6
Assigned To: Douglas Schilling Landgraf
Huijuan Zhao
node
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 03:14 EST by Huijuan Zhao
Modified: 2016-02-10 14:18 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-plugin-vdsm-0.6.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:50:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
bmcclain: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)
screenshot setup rootpw failed (9.45 KB, image/png)
2015-11-09 03:14 EST, Huijuan Zhao
no flags Details
setup rootpw crash log (5.79 MB, application/x-gzip)
2015-11-09 03:18 EST, Huijuan Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48319 ovirt-3.6 MERGED engine_page: Add validation for None type Never
oVirt gerrit 48381 ovirt-3.6 MERGED engine_page: Add validation for None type Never

  None (edit)
Description Huijuan Zhao 2015-11-09 03:14:32 EST
Created attachment 1091562 [details]
screenshot setup rootpw failed

Description of problem:
RHEV-M page crash after setup root password


Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151104.0.e17ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-2.el7ev.noarch


How reproducible:
100%
Whiteboard: regression

Steps to Reproduce:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Change to RHEV-M page, setup root password, click < Save / Register >

Actual results:
1. After step3, RHEV-M page crash and report error like follows.

An error appeared in the UI: TypeError("argument of type 'NoneType' is not iterable",)
Press ENTER to logout ...
or enter 's' to drop to shell


Expected results:
1.After step3, it can setup root password successful.

Additional info:
No such issue on rhev-hypervisor-7-7.2-20151009.0.e17ev, so it is a regression issue.
Comment 1 Huijuan Zhao 2015-11-09 03:18 EST
Created attachment 1091563 [details]
setup rootpw crash log
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-09 08:07:41 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-10 13:55:55 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 4 Huijuan Zhao 2015-11-12 03:18:02 EST
so far RHEV-H build have not been ready to QE although the bug is ON_QA, QE will verify this bug when the build is ready later.
Comment 5 Huijuan Zhao 2015-11-17 00:39:22 EST
Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151112.1.e17ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-3.el7ev.noarch


My Steps:
1. Install rhevh
2. Login rhevh, setup network via dhcp
3. Change to RHEV-M page, setup root password, click < Save / Register >

Test results:
1. After step3, it can setup root password successful.

So this bug is fixed on rhev-hypervisor-7-7.2-20151112.1, I will change the status to verified.
Comment 6 Sandro Bonazzola 2015-11-27 02:50:30 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.