Bug 1279354 - Rollback of RHEV VM fails if disks aren't completely created yet
Rollback of RHEV VM fails if disks aren't completely created yet
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - RHEV (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Ohad Levy
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 04:33 EST by Maxim Burgerhout
Modified: 2017-01-12 14:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 14:14:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Burgerhout 2015-11-09 04:33:51 EST
Description of problem:
When there is an error and the creation of a VM on RHEV needs to be rolled back, Satellite attempts to do this, but fails if the disks for the VM haven't been completely created yet.

My storage is slow, so I have this happen all the time, but if you would create a VM on fast storage with large preallocated disks, I can imagine this happening too.

Error message:

Failed to destroy a compute RHEV (RHEV) instance rhev-test-01.vm.thuisnet.lan: Cannot remove VM: The following disks are locked: rhev-test-01-vm-thuisnet-lan_Disk1. Please try again in a few minutes.

Not sure whether to file this as RHEV or Satellite bug, tbh.

Version-Release number of selected component (if applicable):
6.1.3

How reproducible:


Steps to Reproduce:
1. Fill in 'New host' page to deploy on RHEV
2. Make intentional error in IP address for example
3. 

Actual results:
VM is created, but roll back fails: VM is not removed due to the above error

Expected results:
VM is created, and roll back (VM removal) succeeds

Additional info:
Either Satellite needs to retry if this happens, or RHEV needs to be able to schedule the deletion for after the disks are created.
Comment 2 Bryan Kearney 2016-07-08 16:48:33 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 4 Bryan Kearney 2017-01-12 14:14:47 EST
This is an older bug which I do not envision being addressed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Note You need to log in before you can comment on or make changes to this bug.