Bug 1279372 - plumouthd debug messages are not logged to file
plumouthd debug messages are not logged to file
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: plymouth (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 05:12 EST by Jan Stodola
Modified: 2017-12-18 15:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-18 15:36:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2015-11-09 05:12:59 EST
Description of problem:
plymouthd executed with the "--debug --debug-file=/tmp/plymouth_debug" options doesn't save debug messages to the specified file.

[root@localhost ~]# rpm -q plymouth
plymouth-0.8.9-0.24.20140113.el7.x86_64
[root@localhost ~]# plymouthd --debug --debug-file=/tmp/plymouth_debug
[main.c:2084]                        initialize_environment:initializing minimal work environment
[main.c:1889]                       get_kernel_command_line:opening /proc/cmdline
[main.c:1898]                       get_kernel_command_line:reading kernel command line
[main.c:1919]                       get_kernel_command_line:Kernel command line is: 'BOOT_IMAGE=/vmlinuz-3.10.0-327.el7.x86_64 root=/dev/mapper/rhel-root ro crashkernel=auto rd.lvm.lv=rhel/root rd.lvm.lv=rhel/swap rhgb quiet LANG=en_US.UTF-8
'
[main.c:2103]                        initialize_environment:checking if '/dev/tty1' exists
[main.c:1933]                               check_verbosity:checking if tracing should be enabled
[main.c:2009]                               check_verbosity:tracing shouldn't be enabled!
[main.c:2027]                                 check_logging:checking if console messages should be redirected and logged
[main.c:2036]                                 check_logging:logging will be enabled!
[main.c:2117]                        initialize_environment:source built on Oct 26 2015
[root@localhost ~]# ls -l /tmp/plymouth_debug
ls: cannot access /tmp/plymouth_debug: No such file or directory
[root@localhost ~]#

Version-Release number of selected component (if applicable):
plymouth-0.8.9-0.24.20140113.el7

How reproducible:
always

Steps to Reproduce:
1. plymouthd --debug --debug-file=/tmp/plymouth_debug
2. less /tmp/plymouth_debug

Actual results:
/tmp/plymouth_debug doesn't exist

Expected results:
/tmp/plymouth_debug with debug messages exists
Comment 1 Ray Strode [halfline] 2015-11-09 09:27:41 EST
since plymouth starts in the initrd normally, we don't save the file until plymouth quits.

you can force it to write the debug file as it runs by doing

plymouth.debug=stream:/tmp/plymouth_debug

or more usefully

plymouth.debug=stream:/dev/kmsg

and it will get interlaced with kernel messages and go to the journal.
Comment 2 Jan Stodola 2015-11-09 11:47:57 EST
Thanks for the hint.
The log file is indeed written when I call
# /usr/bin/plymouth quit

It could be useful to mention this information in the man page.

Note You need to log in before you can comment on or make changes to this bug.