Bug 1279373 - docker returns 404 for tagged pull from private registry. (Sat6)
docker returns 404 for tagged pull from private registry. (Sat6)
Status: CLOSED DUPLICATE of bug 1282431
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.1.3
x86_64 Linux
high Severity high (vote)
: Unspecified
: 6.1
Assigned To: satellite6-bugs
Katello QA List
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 05:15 EST by Christophe Augello
Modified: 2015-11-17 13:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 13:50:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Augello 2015-11-09 05:15:49 EST
Description of problem:

Tagged pull from a private registry returns 404 Not found.
docker pull -a from same registry pulls the image including the tagged one.

Version-Release number of selected component (if applicable):

docker-1.8.2-7.el7.x86_64 

How reproducible:

Always

Steps to Reproduce:
1. setup private registry 
2. pull tagged image
~~~
[root@docker ~]# docker pull satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel:7.1-9
Trying to pull repository satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel ... not found
Tag 7.1-9 not found in repository satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel
~~~

3. downgrade docker and pull
~~~
root@docker ~]# yum downgrade docker
<snip>
Removed:
  docker.x86_64 0:1.8.2-7.el7                                                                                                                                                                 
<snip>
Installed:
  docker.x86_64 0:1.7.1-115.el7   

[root@docker ~]# docker pull satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel:7.1-9
Trying to pull repository satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel ...
e3c92c6cff35: Download complete 
Status: Downloaded newer image for satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel:7.1-9                                    
~~

Actual results:

Tagged pull returns 404 not found.

Expected results:

Success full tagged pull as with docker-1.7.1-115.

Additional info:
Comment 2 Daniel Walsh 2015-11-09 07:42:04 EST
Michal any ideas?
Comment 3 Christophe Augello 2015-11-10 05:03:50 EST
Seems to come from pulp-crane plugin.
Issue seems to be solved after applying 
https://github.com/pulp/crane/commit/d4ef8967901651680e0febd3ff54333c86fafed0

[root@docker ~]# rpm -qa | grep docker
docker-selinux-1.8.2-7.el7.x86_64
docker-1.8.2-7.el7.x86_64
docker-registry-0.9.1-7.el7.x86_64

[root@docker ~]# docker pull satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel:7.1-9
Trying to pull repository satellite:5000/red_hat-engineering-ccv-rhel7-docker_ie3c92c6cff35: Pulling image (7.1-9) from satellite:5000/red_hat-engineering-ccve3c92c6cff35: Pulling image (7.1-9) from satellite:5000/red_hat-engineering-ccve3c92c6cff35: Download complete 
Status: Downloaded newer image for satellite:5000/red_hat-engineering-ccv-rhel7-docker_image1-rhel:7.1-9
Comment 4 Mike McCune 2015-11-17 13:50:22 EST

*** This bug has been marked as a duplicate of bug 1282431 ***

Note You need to log in before you can comment on or make changes to this bug.