This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 127939 - Can't add network power controller password from command line
Can't add network power controller password from command line
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-15 11:35 EDT by Mike Levine
Modified: 2009-04-16 16:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 17:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Levine 2004-07-15 11:35:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
redhat-config-cluster-cmd --member=nodec --add_powercontroller --
type=baytech --ipaddress=192.168.200.252 --port=3 --user=admin --
password=admin

Error: option --password not recognized

I tried pass, passwd, and word. All failed.

I also tried 
redhat-config-cluster-cmd --member=nodec --add_powercontroller --
type=baytech --ipaddress=192.168.200.252 --port=3 --user=admin

which worked, then
redhat-config-cluster-cmd --member=nodec --
powercontroller=192.168.200.252,3 --password=admin

gave the same. Error: option --password not recognized

when I do it through the GUI, it works. the xml attribute "password" 
of the powercontroller is set to the password I enter in the X-
windows app.



Version-Release number of selected component (if applicable):
redhat-config-cluster-1.0.2

How reproducible:
Always

Steps to Reproduce:
1.set up a cluster
2.add a network power controller from the command line with a password
3.observe the failure
    

Actual Results:  Error: option --password not recognized
No power controller is added

Expected Results:  A power controller should be added which would 
login with the password I specified

Additional info:

Note You need to log in before you can comment on or make changes to this bug.