Bug 1279398 - [RFE] [admin portal] Sort ISOs from ISO domain in lists in natural (version) sort order
[RFE] [admin portal] Sort ISOs from ISO domain in lists in natural (version) ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0.2
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Idan Shaby
Elad
: EasyFix, FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 06:33 EST by Jiri Belka
Modified: 2016-07-17 21:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
ISO domain files are sorted alphabetically in the Administration portal. This update additionally enables the sorting to take version numbers into consideration. A file named RHEV_3.5.10.iso will now come after a file named RHEV_3.5.5.iso and not before it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:05:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
gklein: testing_plan_complete-
ylavi: planning_ack+
masayag: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
screenshot (237.17 KB, image/png)
2015-11-09 06:33 EST, Jiri Belka
no flags Details
Verification screenshots (58.87 KB, image/png)
2016-05-24 06:34 EDT, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55948 master MERGED webadmin: improve repo images sort 2016-04-12 03:29 EDT

  None (edit)
Description Jiri Belka 2015-11-09 06:33:33 EST
Created attachment 1091692 [details]
screenshot

Description of problem:

[admin portal] Sort isos in lists in natural (version) sort order, so 3.5.10 is not after 3.5.1 but after 3.5.9 for example. Same wasy as `sort -V' does it.

* currently

RHEV 3.5.1
RHEV 3.5.10
RHEV 3.5.3

* proposition (like `cat /tmp/test | sort -V')

RHEV 3.1.0
RHEV 3.5.1
RHEV 3.5.3
RHEV 3.5.10

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0.2-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. have some files in iso domain which contain .1, .[2-9] and .10 as last digit in filename
2. check where is .10 in the list
3.

Actual results:
not naturally (version) sorted

Expected results:
naturally (version) sorted

Additional info:
Comment 3 Moti Asayag 2015-11-11 03:06:46 EST
(In reply to Moti Asayag from comment #2)
> (In reply to Einav Cohen from comment #1)
> > please refer to http://etherpad.corp.redhat.com/whiteboard when filling
> > Whiteboard. 'ui' doesn't exist even. thanks.
> 
> Changed whiteboard to 'infra', since it is related to ovirt-node isos, not
> to storage domain.

And moving back to 'storage', as the ovirt-isos are already sorted properly and seems not to be a concern for this bug.
Comment 4 Elad 2016-05-24 06:34:13 EDT
ISOs are sorted naturally in Run Virtual Machine prompt.

Used: ovirt-engine-4.0.0-0.0.master.20160523171412.git1a7a1f3.el7.centos.noarch

Attaching screenshot.
Comment 5 Elad 2016-05-24 06:34 EDT
Created attachment 1160979 [details]
Verification screenshots
Comment 6 Sandro Bonazzola 2016-07-05 04:05:04 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.