Bug 1279400 - Informix translator - convert function in definition of view is not pushed down
Informix translator - convert function in definition of view is not pushed down
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: 6.3.0
Assigned To: Van Halbert
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 06:33 EST by Juraj Duráni
Modified: 2016-08-24 07:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:34:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3813 Major Closed Informix translator - convert function in definition of view is not pushed down 2016-06-15 03:00 EDT

  None (edit)
Description Juraj Duráni 2015-11-09 06:33:58 EST
I defined a view (see definition below). When I try to select all rows from the view, teiid/informix jdbc driver throws an exception.

Teiid DDL:
CREATE VIEW U6 (StringCol string,
    IntCol integer)
  AS
    SELECT CONVERT(BQT1.SmallA.IntNum, string) AS StringCol, BQT1.SmallA.IntNum AS IntCol
    FROM BQT1.SmallA
    UNION ALL
    SELECT BQT1.SmallB.StringNum, CONVERT(BQT1.SmallB.StringNum, integer)
    FROM BQT1.SmallB;
}

Query:
SELECT * FROM VQT.U6

Source-specific query
SELECT g_1.intnum AS c_0, g_1.intnum AS c_1 FROM smalla AS g_1 UNION ALL SELECT g_0.stringnum AS c_0, g_0.stringnum AS c_1 FROM smallb AS g_0

Actual exception:
Caused by: java.sql.SQLException: The statement failed because corresponding column data types must be compatible for each UNION, INTERSECT, or MINUS query.
	at com.informix.util.IfxErrMsg.getSQLException(IfxErrMsg.java:408)
	at com.informix.jdbc.IfxSqli.addException(IfxSqli.java:3178)
...
Comment 1 JBoss JIRA Server 2015-11-10 15:36:00 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3813 to Resolved
Comment 2 JBoss JIRA Server 2016-01-27 16:25:03 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3813 to Closed

Note You need to log in before you can comment on or make changes to this bug.