Bug 1279434 - ovirt-vmconsole-host-sshd service is not started automatically at boot
ovirt-vmconsole-host-sshd service is not started automatically at boot
Status: CLOSED CURRENTRELEASE
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugin.vmconsole (Show other bugs)
1.4.0
x86_64 Linux
unspecified Severity high (vote)
: ovirt-4.0.0-alpha
: 1.5.0
Assigned To: Yaniv Kaul
Nikolai Sednev
: Triaged
Depends On:
Blocks: 1223671 1280330
  Show dependency treegraph
 
Reported: 2015-11-09 08:03 EST by Nikolai Sednev
Modified: 2016-02-18 06:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1280330 (view as bug list)
Environment:
Last Closed: 2016-02-18 06:08:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
alonbl: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
host's sosreport (6.01 MB, application/x-xz)
2015-11-09 08:05 EST, Nikolai Sednev
no flags Details
engine's sosreport (7.45 MB, application/x-xz)
2015-11-09 08:06 EST, Nikolai Sednev
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48436 master MERGED vmconsole: automatic start of ovirt-vmconsole-host-sshd Never
oVirt gerrit 48437 ovirt-host-deploy-1.4 MERGED vmconsole: automatic start of ovirt-vmconsole-host-sshd Never

  None (edit)
Description Nikolai Sednev 2015-11-09 08:03:02 EST
Description of problem:
ovirt-vmconsole-host-sshd.service is not enabled in systemctl on host, after host added to engine with enabled serial-console-proxy.

Here goes printouts from the host after it was added in to the engine:
# rpm -qa ovirt-vmconsole-host
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
# systemctl is-enabled ovirt-vmconsole-host-sshd.service 
disabled

Initially clean host comes without ovirt-vmconsole-host installed.

Version-Release number of selected component (if applicable):

Host:
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-001-2.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-001-2.noarch
libvirt-client-1.2.17-13.el7.x86_64
vdsm-4.17.10.1-0.el7.centos.noarch
sanlock-3.2.4-1.el7.x86_64
mom-0.5.1-2.el7.noarch
qemu-kvm-rhev-2.3.0-31.el7.x86_64
Linux version 3.10.0-322.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Mon Oct 5 21:41:10 EDT 2015

Engine:
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
ovirt-engine-extension-aaa-jdbc-1.0.1-1.el6ev.noarch
ovirt-host-deploy-1.4.0-1.el6ev.noarch
ovirt-host-deploy-java-1.4.0-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch
rhevm-3.6.0.3-0.1.el6.noarch
rhevm-guest-agent-common-1.0.11-2.el6ev.noarch
qemu-guest-agent-0.12.1.2-2.479.el6_7.2.x86_64
Linux version 2.6.32-573.7.1.el6.x86_64 (mockbuild@x86-031.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC) ) #1 SMP Thu Sep 10 13:42:16 EDT 2015

How reproducible:
100%

Steps to Reproduce:
1.Add clean RHEL7.2 host to the engine with enabled ovirt-vmconsole-proxy on it.
2.Check on added host the if ovirt-vmconsole-host-sshd.service is enabled by running "systemctl is-enabled ovirt-vmconsole-host-sshd.service" command.

Actual results:
# systemctl is-enabled ovirt-vmconsole-host-sshd.service 
disabled


Expected results:
#  systemctl is-enabled ovirt-vmconsole-host-sshd.service 
enabled


Additional info:
sosreports from engine and host attached.
Comment 1 Nikolai Sednev 2015-11-09 08:05 EST
Created attachment 1091731 [details]
host's sosreport
Comment 2 Nikolai Sednev 2015-11-09 08:06 EST
Created attachment 1091732 [details]
engine's sosreport
Comment 3 Alon Bar-Lev 2015-11-09 08:15:09 EST
you always open at wrong component.
Comment 4 Red Hat Bugzilla Rules Engine 2015-11-09 08:15:13 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-09 08:15:13 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 6 Red Hat Bugzilla Rules Engine 2015-11-09 08:16:32 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Red Hat Bugzilla Rules Engine 2015-11-09 08:16:32 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 8 Red Hat Bugzilla Rules Engine 2015-11-09 08:17:16 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Red Hat Bugzilla Rules Engine 2015-11-09 08:17:16 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 10 Alon Bar-Lev 2015-11-09 08:21:15 EST
Michal,
I was under the impression that this should be dependency of vdsm if vdsm use it, like any other dependency.
I can add this to host-deploy, but same as other dependencies we have for vdsm, vdsm makes sure these are started before.
Comment 12 Nikolai Sednev 2015-11-11 07:05:51 EST
Setting back the need info for Michal, set by  Alon Bar-Lev 2015-11-09 08:21:15 EST in comment #10, as wiped it out by mistake, while answered to Comment #11.
Comment 13 Michal Skrivanek 2015-11-11 07:36:59 EST
(In reply to Alon Bar-Lev from comment #10)
> Michal,
> I was under the impression that this should be dependency of vdsm if vdsm
> use it, like any other dependency.
> I can add this to host-deploy, but same as other dependencies we have for
> vdsm, vdsm makes sure these are started before.

we wanted to avoid all the additional work around making it optional initially (hence hard dependency of vdsm at the moment). It would be easy to add to host deploy, even together with vdsm service(which would be a bit more ugly I would say, we did mom this way and it's not particularly problem-free), however if we want to support a deployment on a standalone separate proxy host I think we should consider enabling it by default.
What do you think, Alon?
Comment 14 Alon Bar-Lev 2015-11-11 08:12:19 EST
(In reply to Michal Skrivanek from comment #13)
> (In reply to Alon Bar-Lev from comment #10)
> > Michal,
> > I was under the impression that this should be dependency of vdsm if vdsm
> > use it, like any other dependency.
> > I can add this to host-deploy, but same as other dependencies we have for
> > vdsm, vdsm makes sure these are started before.
> 
> we wanted to avoid all the additional work around making it optional
> initially (hence hard dependency of vdsm at the moment). It would be easy to
> add to host deploy, even together with vdsm service(which would be a bit
> more ugly I would say, we did mom this way and it's not particularly
> problem-free), however if we want to support a deployment on a standalone
> separate proxy host I think we should consider enabling it by default.
> What do you think, Alon?

we disccuss the host not the proxy.

vdsm is already starting optional features if are enabled by configuration during pre-start.
Comment 15 Alon Bar-Lev 2015-11-11 08:26:30 EST
ok, nevermind, will do this in host-deploy.
Comment 16 Red Hat Bugzilla Rules Engine 2015-11-11 08:26:31 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 17 Red Hat Bugzilla Rules Engine 2015-11-11 08:31:45 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 18 Red Hat Bugzilla Rules Engine 2015-11-11 08:31:45 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 19 Nikolai Sednev 2015-11-11 12:14:19 EST
Just tested the: 
ovirt-host-deploy-1.4.1-0.0.master.el6ev.noarch.rpm
ovirt-host-deploy-java-1.4.1-0.0.master.el6ev.noarch.rpm
ovirt-host-deploy-repolib-1.4.1-0.0.master.el6ev.noarch.rpm
Just checked the https://brewweb.devel.redhat.com//buildinfo?buildID=465788

Works for me on these components:
Engine:
rhevm-3.6.0.3-0.1.el6.noarch
rhevm-guest-agent-common-1.0.11-2.el6ev.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch
Linux version 2.6.32-573.7.1.el6.x86_64 (mockbuild@x86-031.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC) ) #1 SMP Thu Sep 10 13:42:16 EDT 2015

Host:
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-13.el7.x86_64
mom-0.5.1-2.el7.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.1.x86_64
vdsm-4.17.10.1-0.el7.centos.noarch
ovirt-release36-002-2.noarch
ovirt-release36-snapshot-002-2.noarch
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
Linux version 3.10.0-327.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Thu Oct 29 17:29:29 EDT 2015
Comment 20 Nikolai Sednev 2015-11-25 02:44:24 EST
Works for me on these components:
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-002-2.noarch
ovirt-engine-sdk-python-3.6.0.4-0.2.20151123.gita2f81ed.el7.centos.noarch
sanlock-3.2.4-1.el7.x86_64
ovirt-setup-lib-1.0.1-0.0.master.20151119123055.gitfa908be.el7.centos.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.3.x86_64
ovirt-hosted-engine-ha-1.3.3-0.0.master.20151118145556.20151118145552.git71b535e.el7.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-002-2.noarch
libvirt-client-1.2.17-13.el7.x86_64
ovirt-hosted-engine-setup-1.3.1-0.0.master.20151118143825.gitc013638.el7.centos.noarch
ovirt-host-deploy-1.4.2-0.0.master.20151122153544.gitfc808fc.el7.noarch
vdsm-4.17.10.1-0.el7ev.noarch
mom-0.5.1-2.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.