Bug 1279450 - gnome-keyring loops when adding new svn passswd (after upgrade F22 -> F23)
gnome-keyring loops when adding new svn passswd (after upgrade F22 -> F23)
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-11-09 08:32 EST by Giuseppe Castagna
Modified: 2016-12-20 10:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-12-20 10:34:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Giuseppe Castagna 2015-11-09 08:32:28 EST
Description of problem:

gnome-keyring prevents svn to exit 

Version-Release number of selected component (if applicable): gnome-keyring-3.18.1-2.fc23.x86_64

How reproducible:

Steps to Reproduce:
1. connect to an svn server using ssh+svn (I have subversion-gnome-1.9.2-1.fc23.x86_64 installed)
   svn up

2. the server answers by asking passwd (usually it should not)

3. enter the password

Actual results:

the command never terminates.

Expected results:

The command should terminate by updating the svn repository 

Additional info:

the svn update sucessfully terminates as soon as I kill the keyring-daemon process.

I tried to remove my  id_ed25519 key from .ssh (since there was a bug related 
to it) but the behaviour did not change.

Useless to say that if I do svn up from a terminal (i.e., without gnome) everthing works fine.
Comment 1 Giuseppe Castagna 2015-11-10 06:59:49 EST
More information : the problem happens when gnome-keyring tries to add a new svn passwd. If the passwd was already present then everything works. I tried with brand new keyrings (by erasing both .local/share/keyrings and legacy .gnome2/keyrings, and it constantly loops whenever I enter a new passwd for a svn server (I changed the summary accordingly)
Comment 2 Giuseppe Castagna 2015-11-14 09:32:33 EST
More information: the problem is not only with svn. It happens also with git. Since someone smartly decided to change in Fedora 23 the credential location from



I had to reenter my passwd ... but of course everyhting loop until I kill the gnome-keyring daemon.
Comment 3 Fedora End Of Life 2016-11-24 08:14:30 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2016-12-20 10:34:28 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.