Bug 1279461 - Not able to upgrade hypervisor using Ovirt engine api
Not able to upgrade hypervisor using Ovirt engine api
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
All Linux
medium Severity medium
: ovirt-3.5.7
: 3.5.7
Assigned To: Moti Asayag
Lukas Svaty
infra
: Regression, ZStream
Depends On: 1278467
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 09:07 EST by rhev-integ
Modified: 2016-02-10 14:14 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278467
Environment:
Last Closed: 2016-01-12 15:40:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48137 master MERGED engine: Invoke UpgradeOvirtNodeCommand when image is provided Never
oVirt gerrit 48262 ovirt-engine-3.6 MERGED engine: Invoke UpgradeOvirtNodeCommand when image is provided Never
oVirt gerrit 48281 ovirt-engine-3.5 MERGED engine: Invoke UpgradeOvirtNodeCommand when image is provided Never

  None (edit)
Comment 2 Lukas Svaty 2015-12-21 03:43:54 EST
VERIFIED in rhevm-backend-3.5.7-0.1.el6ev.noarch

Tested while status up:
[lsvaty@ ~]$ curl -X POST -H "Content-type: application/xml" -u admin@internal:mypass --insecure -d "<action><root_password>mypass</root_password><image>rhevh-latest-6.iso</image></action>" https://example.com/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/install
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<action>
    <root_password>mypass</root_password>
    <image>rhevh-latest-6.iso</image>
    <status>
        <state>failed</state>
    </status>
    <fault>
        <reason>Operation Failed</reason>
        <detail>[Cannot install Host. Please move Host to Maintenance mode first.]</detail>
    </fault>
</action>

While host in maintenance, upgrade successful:
[lsvaty@dhcp131-219 ~]$ curl -X POST -H "Content-type: application/xml" -u admin@internal:mypass --insecure -d "<action><root_password>mypass</root_password><image>rhevh-latest-6.iso</image></action>" https://example.com/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/install
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<action>
    <host href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d" id="8b439483-dea4-436f-947e-88f17f2c022d">
        <actions>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/forceselectspm" rel="forceselectspm"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/approve" rel="approve"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/iscsilogin" rel="iscsilogin"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/unregisteredstoragedomainsdiscover" rel="unregisteredstoragedomainsdiscover"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/iscsidiscover" rel="iscsidiscover"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/commitnetconfig" rel="commitnetconfig"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/fence" rel="fence"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/deactivate" rel="deactivate"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/install" rel="install"/>
            <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/activate" rel="activate"/>
        </actions>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/storage" rel="storage"/>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/nics" rel="nics"/>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/numanodes" rel="numanodes"/>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/tags" rel="tags"/>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/permissions" rel="permissions"/>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/statistics" rel="statistics"/>
        <link href="/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/hooks" rel="hooks"/>
    </host>
    <root_password>mypass</root_password>
    <image>rhevh-latest-6.iso</image>
    <status>
        <state>complete</state>
    </status>
</action>

While host in reboot state after ugprade:
[lsvaty@dhcp131-219 ~]$ curl -X POST -H "Content-type: application/xml" -u admin@internal:mypass --insecure -d "<action><root_password>mypass</root_password><image>rhevh-latest-6.iso</image></action>" https://example.com/api/hosts/8b439483-dea4-436f-947e-88f17f2c022d/install
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<action>
    <root_password>mypass</root_password>
    <image>rhevh-latest-6.iso</image>
    <status>
        <state>failed</state>
    </status>
    <fault>
        <reason>Operation Failed</reason>
        <detail>[Cannot install Host. Please move Host to Maintenance mode first.]</detail>
    </fault>
</action>
[lsvaty@dhcp131-219 ~]$
Comment 4 errata-xmlrpc 2016-01-12 15:40:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0029.html

Note You need to log in before you can comment on or make changes to this bug.