Bug 1279465 - Non-functioning LogMessage example in mod_log_debug documentation
Non-functioning LogMessage example in mod_log_debug documentation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Web Stack Team
Martin Frodl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 09:15 EST by Martin Frodl
Modified: 2016-11-04 04:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: httpd-2.4.6-41
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:09:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-11-09 09:15:17 EST
Description of problem:

The documentation for mod_log_debug (in httpd-manual package) contains four examples one of which is syntactically incorrect and prevents Apache from starting. It uses the following configuration:

<Location "/foo/">
  LogMessage "subrequest to /foo/" hook=type_checker expr=%{IS_SUBREQ}
</Location>

This is how Apache reacts:

# systemctl start httpd
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
# journalctl -xe
...
httpd[2603]: AH00526: Syntax error on line 8 of /etc/httpd/conf.d/custom.conf:
httpd[2603]: Could not parse expression '%{IS_SUBREQ}': syntax error, unexpected $end
...

This is probably a documentation bug, one easily fixable by the following modification which I believe does the desired job (I am no expert at this matter, though):

  LogMessage "subrequest to /foo/" hook=type_checker "expr=-T %{IS_SUBREQ}"
                                                     ^     ^^^            ^

Version-Release number of selected component (if applicable):
httpd-manual-2.4.6-31.el7_1.1.x86_64
Comment 1 Jan Kaluža 2016-01-07 06:46:32 EST
Thanks, fixed upstream: http://svn.apache.org/r1723522.
Comment 7 errata-xmlrpc 2016-11-04 04:09:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2534.html

Note You need to log in before you can comment on or make changes to this bug.