Bug 1279473 - Informix translator - <> ALL is translated as NOT IN - this statement seem to not work in Infromix
Informix translator - <> ALL is translated as NOT IN - this statement seem to...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 6.3.0
Assigned To: David Le Sage
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 09:31 EST by Juraj Duráni
Modified: 2016-08-24 07:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There is an issue with the Informix translator whereby neither neither '<> ALL' or 'NOT IN' works in a query. You must avoid using these statements in your commands.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:41:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3816 Major Closed Informix translator - <> ALL is translated as NOT IN - this statement seem to not work in Infromix 2016-08-11 03:08 EDT

  None (edit)
Description Juraj Duráni 2015-11-09 09:31:52 EST
Query:
SELECT INTKEY, BOOLEANVALUE FROM BQT1.SMALLA WHERE BOOLEANVALUE <> ALL (SELECT BOOLEANVALUE FROM BQT1.SMALLA WHERE INTKEY = 40)

Source-specific command:
SELECT g_0.IntKey, g_0.BooleanValue FROM Source.SmallA AS g_0 WHERE g_0.BooleanValue NOT IN (SELECT g_1.BooleanValue FROM Source.SmallA AS g_1 WHERE g_1.IntKey = 40)

*Note: boolean value for row where Intkey = 40 is false.*

Expected result:
|intkey|booleanvalue|
|1|true|
|...|...|

Actual result:
|intkey|booleanvalue|
|1|false|
|...|...|

This seems to be an Informix issue as neither '<> ALL' nor 'NOT IN' works.
Comment 1 JBoss JIRA Server 2016-01-29 09:58:56 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3816 to Resolved
Comment 2 Van Halbert 2016-02-08 09:04:36 EST
This will need to be release noted.
Comment 3 JBoss JIRA Server 2016-06-03 18:33:59 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3816 to Closed

Note You need to log in before you can comment on or make changes to this bug.