Bug 127948 - copy and paste to clipboard seriously lacking
copy and paste to clipboard seriously lacking
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-15 12:25 EDT by Sepehr
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-15 16:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sepehr 2004-07-15 12:25:53 EDT
Description of problem:
No way to copy and paste from clipboard

Version-Release number of selected component (if applicable):
Lastest

How reproducible:
100%

Steps to Reproduce:
1.copy and image from say OpenOffice Draw
2.Open gimp
3.Select "File/Aquire" menu on main panel.

Actual results:
No "from clipboard" option like Windows Gimp

or 

1.Open bitmap in gimp
2.Select "Edit/" menu on drawing window
  
Actual results:
No "Copy to Clipboard" option like Windows Gimp

or

1.copy and image from say OpenOffice Draw
2.Open bitmap graphic in gimp
3.Select "Edit" menu on drawing window.

Actual results:
No "Paste from Clipboard" option like Windows Gimp

Expected results:
Menus options should be able to copy and paste at will between Gimp
and other applications. Frame work is in the code since it works
perfectly in Windows, why not avaible in Linux???

Additional info:
Comment 1 Nils Philippsen 2004-07-15 16:34:01 EDT
You really cannot compare Copy and Paste on Windows to Copy and Paste
in X -- they are completely different things. Anyway, this bug should
be solved upstream and is in fact already in the GIMP's bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=118507

I will close this bug as UPSTREAM meaning I've subscribed to the
aforementioned bug and as soon as patches are made available, I should
know it and might incorporate them in the package (depending on the
complexity of the patch, i.e. if the patch is against the development
version of the GIMP and backporting is too difficult I might just wait
for the next major version).

BTW: "Latest" for Version/Release is not much information for me --
what is latest for you might be a few releases old for me ;-). Please
make it something like "gimp-2.0.2-1.fc2.2" in the future, thanks.

Note You need to log in before you can comment on or make changes to this bug.