Bug 1279483 - The yum group list ids command does not indicate that there are hidden groups
The yum group list ids command does not indicate that there are hidden groups
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
Eva Mrakova
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 09:40 EST by Stephen Wadeley
Modified: 2016-11-04 01:30 EDT (History)
4 users (show)

See Also:
Fixed In Version: yum-3.4.3-137.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:30:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Wadeley 2015-11-09 09:40:08 EST
Description of problem:

The command `yum group list ids` will sometimes give no output even though there are "hidden" groups.

It sees unreasonable to expect all users to know they must also search for hidden groups.

Combined with that fact that the data is inconsistent between different repos makes it hard to find groups.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

Test commands on both a Server and a Workstation to see the differences.

1.  ~]# yum group list ids kde\*
2. ~]# yum group info KDE
3.

Actual results:
Testing on a 7.1 server;
Nothing here:

[root@localhost ~]# yum group list ids kde\*
Loaded plugins: product-id, subscription-manager
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
Warning: no environments/groups match: ids, kde*

But this works:

[root@localhost ~]# yum group info KDE
Loaded plugins: product-id, subscription-manager

Group: KDE
 Group-Id: kde-desktop

{and works with lower case kde too}

But does not mention @kde
[root@localhost ~]# yum grouplist
Loaded plugins: product-id, subscription-manager
Available environment groups:
   Minimal Install
   Infrastructure Server
   File and Print Server
   Basic Web Server
   Virtualization Host
   Server with GUI
Installed groups:
   Security Tools
   System Administration Tools
Available Groups:
   Compatibility Libraries
   Console Internet Tools
   Development Tools
   Graphical Administration Tools
   Legacy UNIX Compatibility
   RT
   SAP
   Scientific Support
   System Management
Done

#Testing on same 7.1 server VM:

[root@localhost ~]# rpm -q yum
yum-3.4.3-124.el7.noarch

[root@localhost ~]# yum group list ids kde\*
Loaded plugins: product-id, subscription-manager
Warning: no environments/groups match: ids, kde*

[root@localhost ~]# yum group list hidden ids | grep -i kde
   KDE (kde-desktop)

[root@localhost ~]# yum group list hidden ids kde\*
Loaded plugins: product-id, subscription-manager
Available Groups:
   KDE (kde-desktop)
Done

These work on the server:
yum group install KDE
yum install @KDE
yum install @kde-desktop



Expected results:

If possible, if yum did not show any groups then show hidden groups. If not possible, print note to say there might be hidden groups and explain how to check for them.
Comment 12 errata-xmlrpc 2016-11-04 01:30:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2397.html

Note You need to log in before you can comment on or make changes to this bug.