Bug 1279494 - DDL for UDF in exported dynamic VDB contains RETURN parameter
DDL for UDF in exported dynamic VDB contains RETURN parameter
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Barry LaFond
Andrej Smigala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 10:05 EST by Andrej Smigala
Modified: 2016-04-14 14:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 08:30:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2719 Major Closed DDL for UDF in exported dynamic VDB contains RETURN parameter 2016-04-14 14:49 EDT

  None (edit)
Description Andrej Smigala 2015-11-09 10:05:22 EST
When exporting VDB with a UDF, the resulting DDL contains the RETURN parameter in the parameters list. According to the Teiid docs, the return parameter should not be specified.

Generated DDL:

CREATE VIRTUAL FUNCTION concatNull (stringLeft string(4000), stringRight string(4000), result string(4000)) RETURNS string

) OPTIONS("FUNCTION-CATEGORY" 'MY_TESTING_FUNCTION_CATEGORY', JAVA_CLASS 'userdefinedfunctions.MyConcatNull', JAVA_METHOD 'myConcatNull')

Expected DDL:

CREATE VIRTUAL FUNCTION concatNull (stringLeft string(4000), stringRight string(4000)) RETURNS string

 OPTIONS("FUNCTION-CATEGORY" 'MY_TESTING_FUNCTION_CATEGORY', JAVA_CLASS 'userdefinedfunctions.MyConcatNull', JAVA_METHOD 'myConcatNull')

(note that the generated DDL also contains an unrelated syntax error due to TEIIDDES-2697)
Comment 2 JBoss JIRA Server 2015-11-30 16:07:54 EST
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2719 to Resolved
Comment 3 Barry LaFond 2015-12-07 08:30:30 EST
Using only JIRA now.  Marking as closed
Comment 4 JBoss JIRA Server 2016-02-19 04:15:31 EST
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2719 to Closed
Comment 5 JBoss JIRA Server 2016-04-14 14:38:50 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2719 to Reopened
Comment 6 JBoss JIRA Server 2016-04-14 14:49:09 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2719 to Closed

Note You need to log in before you can comment on or make changes to this bug.