Bug 1279512 - Messages JBAS014612: Operation ("read-resource") failed ... logged for rhq.ear/rhq-core-domain-ejb3.jar#rhqpu resource
Messages JBAS014612: Operation ("read-resource") failed ... logged for rhq.ea...
Status: CLOSED DUPLICATE of bug 1158947
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.3.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michael Burman
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 10:45 EST by bkramer
Modified: 2015-11-12 11:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 11:00:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2015-11-09 10:45:22 EST
Description of problem:
JBoss ON Server is throwing the following error:

************************************************
08:55:32,669 ERROR [org.jboss.as.controller.management-operation] (HttpManagementService-threads - 4770) JBAS014612: Operation ("read-resource") failed - address: ([
    {"deployment" => "rhq.ear"},
    {"subdeployment" => "rhq-core-domain-ejb3.jar"},
    {"subsystem" => "jpa"},
    {"hibernate-persistence-unit" => "rhq.ear/rhq-core-domain-ejb3.jar#rhqpu"}
]): java.lang.StringIndexOutOfBoundsException: String index out of range: 0
	at java.lang.String.charAt(String.java:658) [rt.jar:1.7.0_75]
	at org.jboss.as.controller.PathElement.<init>(PathElement.java:103) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.PathElement.pathElement(PathElement.java:68) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.operations.global.ReadResourceHandler.doExecuteInternal(ReadResourceHandler.java:220) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.operations.global.ReadResourceHandler.doExecute(ReadResourceHandler.java:142) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.operations.global.GlobalOperationHandlers$AbstractMultiTargetHandler.execute(GlobalOperationHandlers.java:249) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:611) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:489) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:290) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:285) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.OperationContextImpl.executeOperation(OperationContextImpl.java:1132) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.ModelControllerImpl.internalExecute(ModelControllerImpl.java:251) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.ModelControllerImpl.execute(ModelControllerImpl.java:152) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.ModelControllerImpl$3.execute(ModelControllerImpl.java:474) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.controller.ModelControllerImpl$3.execute(ModelControllerImpl.java:464) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.DomainApiHandler.processRequest(DomainApiHandler.java:263) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.DomainApiHandler.doHandle(DomainApiHandler.java:167) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.DomainApiHandler.handle(DomainApiHandler.java:174) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.security.SubjectAssociationHandler$1.run(SubjectAssociationHandler.java:69) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.security.SubjectAssociationHandler$1.run(SubjectAssociationHandler.java:65) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_75]
	at javax.security.auth.Subject.doAs(Subject.java:415) [rt.jar:1.7.0_75]
	at org.jboss.as.controller.AccessAuditContext.doAs(AccessAuditContext.java:94) [jboss-as-controller-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.security.SubjectAssociationHandler.handleRequest(SubjectAssociationHandler.java:65) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.security.SubjectAssociationHandler.handle(SubjectAssociationHandler.java:59) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.DomainApiCheckHandler.handle(DomainApiCheckHandler.java:45) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:78)
	at org.jboss.sun.net.httpserver.AuthFilter.doFilter(AuthFilter.java:69)
	at org.jboss.com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:81)
	at org.jboss.sun.net.httpserver.ServerImpl$Exchange$LinkHandler.handle(ServerImpl.java:710)
	at org.jboss.com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:78)
	at org.jboss.as.domain.http.server.RealmReadinessFilter.doFilter(RealmReadinessFilter.java:47) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.as.domain.http.server.DmrFailureReadinessFilter.doFilter(DmrFailureReadinessFilter.java:45) [jboss-as-domain-http-interface-7.4.3.Final-redhat-2.jar:7.4.3.Final-redhat-2]
	at org.jboss.com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:81)
	at org.jboss.sun.net.httpserver.ServerImpl$Exchange.run(ServerImpl.java:682)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_75]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_75]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_75]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.1.Final-redhat-1.jar:2.1.1.Final-redhat-1]
************************************************

Version-Release number of selected component (if applicable):
JBoss ON 3.3.3 

How reproducible:
Unfortunately no repo steps. 


According to the solution: "rhq.ear/rhq-core-domain-ejb3.jar#rhqpu" resource unavailable in JBoss ON (https://access.redhat.com/solutions/735903) - this error will happen when rhq.ear/rhq-core-domain-ejb3.jar#rhqpu resource (bean) is not active for a longer time period. In that case, this bean will be passivated and as such it's availability will be considered as DOWN although it is really UP. The issue was logged previously against JBoss ON 3.2.0 ER5 in Bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1028468 and was closed as fixed in JBoss ON 3.3.0.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Filip Brychta 2015-11-12 11:00:49 EST

*** This bug has been marked as a duplicate of bug 1158947 ***

Note You need to log in before you can comment on or make changes to this bug.