Bug 1279544 - Nested stack remains IN_PROGRESS even though none of its resources are IN_PROGRESS
Nested stack remains IN_PROGRESS even though none of its resources are IN_PRO...
Status: CLOSED DUPLICATE of bug 1267558
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: async
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 12:10 EST by Jiri Stransky
Modified: 2016-04-27 00:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 12:51:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
heat CLI queries (14.25 KB, text/plain)
2015-11-09 12:18 EST, Jiri Stransky
no flags Details
heat-engine.log (405.95 KB, text/plain)
2015-11-09 12:19 EST, Jiri Stransky
no flags Details
heat-engine journal (14.76 KB, text/x-vhdl)
2015-11-09 12:19 EST, Jiri Stransky
no flags Details

  None (edit)
Description Jiri Stransky 2015-11-09 12:10:52 EST
I hit this when testing OSP-d updates. One of the nested stacks is in UPDATE_IN_PROGRESS, even though all of its resources are UPDATE_COMPLETE or CREATE_COMPLETE.

heat-engine.log is rapidly flooding with the same lines, related to resource registry. There's also an error in heat-engine journal but that showed up during a single occasion, it's not appearing repeatedly.

[root@instack ~]# yum list installed | grep heat
heat-cfntools.noarch               1.2.8-2.el7            @rhelosp-7.0-puddle   
openstack-heat-api.noarch          2015.1.1-7.el7ost      @rhelosp-7.0-puddle   
openstack-heat-api-cfn.noarch      2015.1.1-7.el7ost      @rhelosp-7.0-puddle   
openstack-heat-api-cloudwatch.noarch
openstack-heat-common.noarch       2015.1.1-7.el7ost      @rhelosp-7.0-puddle   
openstack-heat-engine.noarch       2015.1.1-7.el7ost      @rhelosp-7.0-puddle   
openstack-heat-templates.noarch    0-0.6.20150605git.el7ost
openstack-tripleo-heat-templates.noarch
python-heatclient.noarch           0.6.0-1.el7ost         @rhelosp-7.0-puddle
Comment 1 Jiri Stransky 2015-11-09 12:18 EST
Created attachment 1091875 [details]
heat CLI queries
Comment 2 Jiri Stransky 2015-11-09 12:19 EST
Created attachment 1091876 [details]
heat-engine.log
Comment 3 Jiri Stransky 2015-11-09 12:19 EST
Created attachment 1091877 [details]
heat-engine journal
Comment 4 Zane Bitter 2015-11-09 12:51:54 EST
INFO logs about the resource registry are normal on any command that loads the stack.

The log in the journal appears to occur only during the undercloud update, when RabbitMQ is not reachable.

After some debugging on the box, I discovered that there were hooks set, and this was the reason that the update was not proceeding. This was likely caused by a previous operation, so I'm closing this as a duplicate of bug 1267558.

*** This bug has been marked as a duplicate of bug 1267558 ***

Note You need to log in before you can comment on or make changes to this bug.