Bug 1279550 - ceres-solver needs to be rebuild against recently updated eigen
ceres-solver needs to be rebuild against recently updated eigen
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ceres-solver (Show other bugs)
epel7
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Taylor Braun-Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 12:20 EST by Chris Moore
Modified: 2015-12-30 13:04 EST (History)
2 users (show)

See Also:
Fixed In Version: ceres-solver-1.11.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 13:04:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Moore 2015-11-09 12:20:00 EST
Description of problem:

Consumers of ceres-solver libraray are required to use the same version of Eigen3 that ceres-solver was build against.  The current version of ceres-solver was built against Eigen 3.2.3, but the repository contains Eigen 3.2.5.  

Version-Release number of selected component (if applicable): 
ceres-sover[-devel] 1.10.0-5.el7
centos 7
eigen3-devel 3.2.5

How reproducible: Always

Steps to Reproduce:
1. Create a CMakeLists.txt with these lines:

cmake_minimum_required(VERSION 2.8.11)
project(CeresEigenTest)
find_package(Ceres REQUIRED)

2. mkdir build; cd build; cmake ../

Actual results:

cmake fails with an error:

CMake Error at /usr/share/Ceres/CeresConfig.cmake:85 (MESSAGE):
  Failed to find Ceres - Missing required Ceres dependency: Eigen version
  3.2.3, please set EIGEN_INCLUDE_DIR.

Expected results:

Expect that the versions in the repository are compatible with each other.  Cmake should find and use eigen 3.2.5.


Additional info:
Comment 1 Rich Mattes 2015-11-16 18:41:48 EST
Thanks for the report.  Since I'm rebuilding the package, I'll also update from 1.11.0-rc2 to 1.11.0 final.
Comment 2 Rich Mattes 2015-11-16 20:05:00 EST
Actually it looks like 1.11.0-rc2 was built but never submitted to epel 7.  I will see what's going on there.
Comment 3 Fedora Update System 2015-12-05 23:27:18 EST
ceres-solver-1.11.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-0eb804e660
Comment 4 Fedora Update System 2015-12-08 02:22:30 EST
ceres-solver-1.11.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update ceres-solver'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-0eb804e660
Comment 5 Fedora Update System 2015-12-30 13:04:09 EST
ceres-solver-1.11.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.