Bug 1279555 - Add drop-in dir for vdsm configuration file
Add drop-in dir for vdsm configuration file
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.11
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.1
: 4.18.5
Assigned To: Irit Goihman
Lucie Leistnerova
: ZStream
: 1164550 (view as bug list)
Depends On:
Blocks: 1260746
  Show dependency treegraph
 
Reported: 2015-11-09 12:40 EST by Fabian Deutsch
Modified: 2016-08-22 08:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 08:29:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.z+
rule-engine: planning_ack+
ybronhei: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48316 master ABANDONED vdsm.conf: Add drop-in dir Never
oVirt gerrit 48317 master MERGED vdsm.conf: Add drop-in dir 2016-06-07 03:48 EDT
oVirt gerrit 58721 ovirt-4.0 ABANDONED vdsm.conf: Add drop-in dir 2016-06-17 20:51 EDT
oVirt gerrit 58728 master MERGED vdsm.conf: Add drop-in dir 2016-06-27 03:59 EDT
oVirt gerrit 59802 ovirt-4.0 MERGED vdsm: removed unnecessary calls to vdsm config.read 2016-06-28 04:59 EDT
oVirt gerrit 59858 ovirt-4.0 MERGED vdsm.conf: Add drop-in dir 2016-06-28 05:27 EDT

  None (edit)
Description Fabian Deutsch 2015-11-09 12:40:51 EST
Description of problem:
It would be nice to have a drop-in dir for the vdsm.conf file, i.e.:
/etc/vdsm/vdsm.conf.d/

Conf files put into that directory could then be used to override directives in the vdsm.conf files.

My usage scenario would be: I manipulate the vdsm.conf file right after installation. But at registration time the vdsm.conf file get's re-written.
If we had the snippets, the snippet would be kept and would survive the registration.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Bronhaim 2015-11-11 02:15:44 EST
*** Bug 1164550 has been marked as a duplicate of this bug. ***
Comment 2 Oved Ourfali 2015-12-31 02:56:09 EST
Fabian - I'm putting this on you, as I see you're the owner of the patch.
Comment 3 Mike McCune 2016-03-28 18:35:49 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Fabian Deutsch 2016-05-09 07:23:22 EDT
Any chance that someone can take this over?
Comment 5 Red Hat Bugzilla Rules Engine 2016-05-15 04:17:25 EDT
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.
Comment 8 Oved Ourfali 2016-05-26 04:00:16 EDT
Irit - should the bug move to POST now that you have a patch addressing it?
Comment 9 Lucie Leistnerova 2016-08-18 07:45:16 EDT
after intalling host - directory /etc/vdsm/vdsm.conf.d/ created
files there are with 'vdsm-tool configure' processed

verified in vdsm-4.18.11-1.el7ev.x86_64

Note You need to log in before you can comment on or make changes to this bug.