Bug 1279564 - deadlock in mep delete post op
deadlock in mep delete post op
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
Depends On: 1278585
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 13:31 EST by Jan Kurik
Modified: 2016-04-25 08:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-67.el6_7
Doc Type: Bug Fix
Doc Text:
In the back end deletion, a transaction info was not passed to one of the database helper functions. Consequently, if a plug-in attempted to access data in the area locked by the transaction, a deadlock situation could occur. Now, the transaction info is passed to all the necessary database helper functions, and a deadlock no longer occurs in the described situation.
Story Points: ---
Clone Of: 1278585
Environment:
Last Closed: 2015-12-15 08:31:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-09 13:31:13 EST
This bug has been copied from bug #1278585 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 4 Sankar Ramalingam 2015-11-26 08:17:54 EST
Attachments are available in this ticket - https://fedorahosted.org/389/ticket/47976. 
We need to either run lot_mods.sh script as Noriko mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1278585#c0 or 
Download the patch from upstream ticket #47976. Then copy the file(ticket47976_test.py) to ds/dirsrtests/tickets/ directory and run the tests from pytest/lib389.

So, I ran the patch from upstream ticket to verify the bug. Execution successfully completed. Hence, marking the bug as Verified.

//etc/sysconfig/dirsrv-*
INFO:lib389:List from /root/.dirsrv
INFO:lib389:list instance {'RUN_DIR': '/var/run/dirsrv', 'SERVER_ID': 'standalone', 'hostname': 'localhost.localdomain', 'ldap-port': 31389, 'ldap-secureport': None, 'DS_ROOT': '', 'deployed-dir': '/', 'INST_DIR': '/usr/lib64/dirsrv/slapd-standalone', 'SERVER_DIR': '/usr/lib64/dirsrv', 'server-id': 'standalone', 'SERVERBIN_DIR': '/usr/sbin', 'root-dn': 'cn=Directory Manager', 'user-id': 'dirsrv', 'CONFIG_DIR': '/etc/dirsrv/slapd-standalone', 'PRODUCT_NAME': 'slapd', 'suffix': 'dc=example,dc=com'}

DEBUG:lib389:running: /usr/sbin/remove-ds.pl -i slapd-standalone 
Instance slapd-standalone removed.

===== 4 passed in 215.01 seconds ===== 

[root@iceman export]# rpm -qa |grep -i 389-ds-base
389-ds-base-devel-1.2.11.15-67.el6_7.x86_64
389-ds-base-1.2.11.15-67.el6_7.x86_64
389-ds-base-libs-1.2.11.15-67.el6_7.x86_64
389-ds-base-debuginfo-1.2.11.15-67.el6_7.x86_64
Comment 6 errata-xmlrpc 2015-12-15 08:31:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2640.html

Note You need to log in before you can comment on or make changes to this bug.