Bug 1279573 - nunc-stans: Attempt to release connection that is not acquired
nunc-stans: Attempt to release connection that is not acquired
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
Depends On: 1271330
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 14:03 EST by Jan Kurik
Modified: 2015-12-08 05:34 EST (History)
8 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.4.0-20.el7_2
Doc Type: Bug Fix
Doc Text:
Previously, the function acquiring a connection was called in an assert call. As a consequence, the function acquiring a connection was not called if the build was not a debugging build, which caused the connection reference count to become out of sequence. Now, the function acquiring a connection is called regardless of the build type, and connection reference count mismatching no longer occurs.
Story Points: ---
Clone Of: 1271330
Environment:
Last Closed: 2015-12-08 05:34:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-09 14:03:54 EST
This bug has been copied from bug #1271330 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Viktor Ashirov 2015-11-26 10:30:32 EST
Build tested: 389-ds-base-1.3.4.0-21.el7_2.x86_64

1. Enable nunc stans and restart the server
nsslapd-enable-nunc-stans: on

2. Add 1k users with ldclt
ldclt -h localhost -p 389 -D "cn=Directory Manager" -w Secret123 -f cn=MrXXXXXX -b "ou=people,dc=example,dc=com" -e add,person,incr,noloop,commoncounter -r0 -R1000

3. Check errors log for "Attempt to release connection that is not acquired"
grep "Attempt to release connection that is not acquired" -c /var/log/dirsrv/slapd-instance/errors
0

Marking as VERIFIED.
Comment 6 errata-xmlrpc 2015-12-08 05:34:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2572.html

Note You need to log in before you can comment on or make changes to this bug.