Bug 1279580 - Missing win32 APIs (such as zip_source_win32w)
Missing win32 APIs (such as zip_source_win32w)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw-libzip (Show other bugs)
23
All Windows
unspecified Severity medium
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 14:29 EST by Gene Hightower
Modified: 2015-11-21 21:24 EST (History)
2 users (show)

See Also:
Fixed In Version: mingw-libzip-1.0.1-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-21 21:24:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
little test program you can use in C++ (1.88 KB, text/x-csrc)
2015-11-09 14:29 EST, Gene Hightower
no flags Details

  None (edit)
Description Gene Hightower 2015-11-09 14:29:52 EST
Created attachment 1091911 [details]
little test program you can use in C++

Description of problem:

It seems the automake build does not include the Win32 files:
zip_source_win32a.c
zip_source_win32handle.c
zip_source_win32utf8.c
zip_source_win32w.c
in the library.  Looks like the Cmake style build is used for Windows so
maybe nobody noticed that you don't get the new Windows APIs if you build
with Automake.  

The new Windows APIs are a big reason to use the new 1.0.1 version.

Version-Release number of selected component (if applicable):

1.0.1-2

How reproducible:

Try to link code with a call to zip_source_win32w_create.  I have attached a C++ program you can use.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2015-11-09 15:50:25 EST
mingw-libzip-1.0.1-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e644e4587a
Comment 2 Fedora Update System 2015-11-10 21:23:53 EST
mingw-libzip-1.0.1-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mingw-libzip'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-e644e4587a
Comment 3 Fedora Update System 2015-11-21 21:24:29 EST
mingw-libzip-1.0.1-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.