This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1279606 - multiple ERRORS of the form "[ActiveRecord::StatementInvalid]: PG::UndefinedTable: ERROR: missing FROM-clause entry for table "vms" "
multiple ERRORS of the form "[ActiveRecord::StatementInvalid]: PG::Undefined...
Status: CLOSED DUPLICATE of bug 1279603
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Joe Rafaniello
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 15:37 EST by Thomas Hennessy
Modified: 2015-11-20 11:00 EST (History)
2 users (show)

See Also:
Fixed In Version: jocarter@redhat.com, mfeifer@redhat.com, jdeubel@redhat.com,
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 11:00:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-11-09 15:37:04 EST
Description of problem: postgresql errors reflected into the evm.log while attempting to create a report.


Version-Release number of selected component (if applicable):
5.5.0.9-beta2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
full sequence from reporting worker log from message dequeue to message delivered:
=====
[----] I, [2015-11-06T11:04:41.815900 #2889:e01988]  INFO -- : MIQ(MiqReportingWorker::Runner#get_message_via_drb) Message id: [441000000007824], MiqWorker id: [441000000000022], Zone: [], Role: [reporting], Server: [], Ident: [reporting], Target id: [], Instance id: [441000000000082], Task id: [], Command: [MiqReport.build_report_result], Timeout: [3600], Priority: [100], State: [dequeue], Deliver On: [], Data: [], Args: [441000000000095, {:send_email=>false, :userid=>"admin"}, {:at=>2015-11-06 15:00:00 -0500, :source=>"Scheduled"}], Dequeued in: [258.423110912] seconds
[----] I, [2015-11-06T11:04:41.823942 #2889:e01988]  INFO -- : MIQ(MiqReport#build_report_result) Generating report table with taskid [441000000000095] and options [{:send_email=>false, :userid=>"admin"}]
[----] I, [2015-11-06T11:04:41.825994 #2889:e01988]  INFO -- : MIQ(MiqTask#update_status) Task: [441000000000095] [Active] [Ok] [Generating report]
[----] E, [2015-11-06T11:04:41.863264 #2889:e01988] ERROR -- : [ActiveRecord::StatementInvalid]: PG::UndefinedTable: ERROR:  missing FROM-clause entry for table "vms"
LINE 1: ...lups"."time_profile_id" = 441000000000001 AND ((((vms.boot_t...
                                                             ^
: SELECT "metric_rollups".* FROM "metric_rollups" WHERE (resource_type = 'VmOrTemplate' and resource_id IS NOT NULL) AND "metric_rollups"."capture_interval_name" = $1 AND "metric_rollups"."time_profile_id" = 441000000000001 AND ((((vms.boot_time IS NOT NULL) AND vms.power_state LIKE '%on%'))) AND (timestamp BETWEEN '2015-11-03 23:00:00.000000' AND '2015-11-05 23:00:00.000000')  Method:[rescue in _async_generate_table]
[----] E, [2015-11-06T11:04:41.863464 #2889:e01988] ERROR -- : /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:637:in `prepare'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:637:in `prepare_statement'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:596:in `exec_cache'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:585:in `execute_and_clear'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql/database_statements.rb:160:in `exec_query'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:355:in `select'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:32:in `select_all'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/abstract/query_cache.rb:70:in `select_all'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/querying.rb:39:in `find_by_sql'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:639:in `exec_queries'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:515:in `load'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:243:in `to_a'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:622:in `blank?'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activesupport/lib/active_support/core_ext/object/blank.rb:24:in `present?'
/var/www/miq/vmdb/app/models/rbac.rb:319:in `filtered'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:245:in `_generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:176:in `block in generate_table'
/var/www/miq/vmdb/app/models/user.rb:299:in `with_user'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:176:in `generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator/async.rb:93:in `_async_generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:755:in `build_report_result'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:323:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:142:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:123:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:24:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
[----] W, [2015-11-06T11:04:41.913731 #2889:e01988]  WARN -- : <AuditFailure> MIQ(Async.rescue in _async_generate_table) userid: [admin] - PG::UndefinedTable: ERROR:  missing FROM-clause entry for table "vms"
LINE 1: ...lups"."time_profile_id" = 441000000000001 AND ((((vms.boot_t...
                                                             ^
: SELECT "metric_rollups".* FROM "metric_rollups" WHERE (resource_type = 'VmOrTemplate' and resource_id IS NOT NULL) AND "metric_rollups"."capture_interval_name" = $1 AND "metric_rollups"."time_profile_id" = 441000000000001 AND ((((vms.boot_time IS NOT NULL) AND vms.power_state LIKE '%on%'))) AND (timestamp BETWEEN '2015-11-03 23:00:00.000000' AND '2015-11-05 23:00:00.000000')
[----] E, [2015-11-06T11:04:41.921632 #2889:e01988] ERROR -- : MIQ(MiqQueue#deliver) Message id: [441000000007824], Error: [PG::UndefinedTable: ERROR:  missing FROM-clause entry for table "vms"
LINE 1: ...lups"."time_profile_id" = 441000000000001 AND ((((vms.boot_t...
                                                             ^
: SELECT "metric_rollups".* FROM "metric_rollups" WHERE (resource_type = 'VmOrTemplate' and resource_id IS NOT NULL) AND "metric_rollups"."capture_interval_name" = $1 AND "metric_rollups"."time_profile_id" = 441000000000001 AND ((((vms.boot_time IS NOT NULL) AND vms.power_state LIKE '%on%'))) AND (timestamp BETWEEN '2015-11-03 23:00:00.000000' AND '2015-11-05 23:00:00.000000')]
[----] E, [2015-11-06T11:04:41.921966 #2889:e01988] ERROR -- : [ActiveRecord::StatementInvalid]: PG::UndefinedTable: ERROR:  missing FROM-clause entry for table "vms"
LINE 1: ...lups"."time_profile_id" = 441000000000001 AND ((((vms.boot_t...
                                                             ^
: SELECT "metric_rollups".* FROM "metric_rollups" WHERE (resource_type = 'VmOrTemplate' and resource_id IS NOT NULL) AND "metric_rollups"."capture_interval_name" = $1 AND "metric_rollups"."time_profile_id" = 441000000000001 AND ((((vms.boot_time IS NOT NULL) AND vms.power_state LIKE '%on%'))) AND (timestamp BETWEEN '2015-11-03 23:00:00.000000' AND '2015-11-05 23:00:00.000000')  Method:[rescue in deliver]
[----] E, [2015-11-06T11:04:41.922504 #2889:e01988] ERROR -- : /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:637:in `prepare'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:637:in `prepare_statement'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:596:in `exec_cache'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:585:in `execute_and_clear'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/postgresql/database_statements.rb:160:in `exec_query'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:355:in `select'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:32:in `select_all'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/connection_adapters/abstract/query_cache.rb:70:in `select_all'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/querying.rb:39:in `find_by_sql'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:639:in `exec_queries'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:515:in `load'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:243:in `to_a'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activerecord/lib/active_record/relation.rb:622:in `blank?'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activesupport/lib/active_support/core_ext/object/blank.rb:24:in `present?'
/var/www/miq/vmdb/app/models/rbac.rb:319:in `filtered'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:245:in `_generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:176:in `block in generate_table'
/var/www/miq/vmdb/app/models/user.rb:299:in `with_user'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:176:in `generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator/async.rb:93:in `_async_generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:755:in `build_report_result'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:323:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:142:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:123:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:24:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
[----] I, [2015-11-06T11:04:41.922901 #2889:e01988]  INFO -- : MIQ(MiqQueue#delivered) Message id: [441000000007824], State: [error], Delivered in [0.106791021] seconds
=====
Comment 2 Thomas Hennessy 2015-11-10 09:34:50 EST
the first line in the provided log extract is the INFO log line detailing all of the information regarding the report id and the target of the report.  Since it has never been clear to me which field has the report id and which field has the target id, I am providing a complete dump of the 123 standard reports that are in the testing system so that you can determine which report is responsible for this error.

=====
441000000000001;"VMs with Free Space > 50% by Department";"VMs with Volume Free Space > 50% by Department"
441000000000002;"VMs w/Free Space > 75% by Function";"VMs with Volume Free Space > 75% by Function"
441000000000003;"VMs w/Free Space > 75% by LOB";"VMs with Volume Free Space > 75% by Line of Business"
441000000000004;"VM Disk Usage";"VM Disk Usage"
441000000000005;"Hardware Information for VMs";"Hardware Information for VMs"
441000000000006;"Vendor and Type";"VM Vendor and Type"
441000000000007;"Vendor and Guest OS";"Vendor and Guest OS"
441000000000008;"VM Location and Size";"VM Location and Size"
441000000000009;"VM UUIDs";"VM Guest OS UUIDs"
441000000000010;"VMs with no UUID";"VMs with no UUID"
441000000000011;"VMs with Volume Free Space <= 20%";"VMs with Volume Free Space <= 20%"
441000000000012;"VMs with Volume Free Space >= 80%";"VMs with Volume Free Space >= 80%"
441000000000013;"VMs by MAC Address";"VMs by MAC Addresses"
441000000000014;"Unregistered VMs";"VMs on Datastore but not registered to a Host"
441000000000015;"Orphaned VMs";"VMs in EVM that have been deleted from VC"
441000000000016;"VMs Snapshot Summary";"VMs Snapshot Summary"
441000000000017;"User Accounts - Windows";"VM User Accounts for Windows"
441000000000018;"User Accounts - Linux";"VM User Accounts for Linux"
441000000000019;"Account Groups - Windows";"VM Account Groups for Windows"
441000000000020;"Account Groups - Linux";"VM Account Groups for Linux"
441000000000021;"Guest OS Information - any OS";"Guest OS Information - any OS"
441000000000022;"Guest OS Information - Windows";"Guest OS Information for Windows"
441000000000023;"Guest OS Information - Linux";"Guest OS Information for Linux"
441000000000024;"Guest OS Password Information - Windows";"Guest OS Password Information for Windows"
441000000000025;"Guest OS HKLM Registry Information";"Guest OS HKLM Registry Information"
441000000000026;"Hosts Summary";"Hosts - Summary by Version"
441000000000027;"Host Summary with VM info";"Host Summary with VM info"
441000000000028;"Virtual Infrastructure Platforms";"Virtual Infrastructure Platforms"
441000000000029;"Host - ESX Services";"ESX Services"
441000000000030;"Host - ESX Service Console Packages";"ESX Service Console Packages"
441000000000031;"Date brought under Management for Last Week";"Hosts: Date brought under Management for Last Week"
441000000000032;"Hardware Information";"Hardware information for Hosts"
441000000000033;"Host Summary for VMs";"Host Summary for VMs"
441000000000034;"Host Patches";"Hosts - Installed Patches"
441000000000035;"Host VM Relationships";"Host to VM Relationships"
441000000000036;"Host Storage Adapters";"Hosts - Storage Adapters Information"
441000000000037;"Host Network Information";"Hosts - Network Information"
441000000000038;"Host vLANs and vSwitches";"Hosts - vLANs and vSwitches"
441000000000039;"Providers Summary";"Providers Summary"
441000000000040;"Providers Hosts Relationships";"Providers Hosts Relationships"
441000000000041;"Providers VMs Relationships";"Providers VMs Relationships"
441000000000042;"Watermark Host Sockets per Provider";"Watermark Host Sockets per Provider"
441000000000043;"Watermark VMs per Provider";"Watermark VMs per Provider"
441000000000044;"Clusters Summary";"Clusters Summary"
441000000000045;"Cluster Hosts Affinity";"Cluster to Hosts Affinity"
441000000000046;"Cluster VMs Affinity with Power State";"Cluster tp VMs Affinity with Power State"
441000000000058;"Number of Nodes per CPU Cores";"Number of Nodes per CPU Cores"
441000000000047;"Cluster Resources";"Cluster Resources"
441000000000048;"Resource Pools Summary";"Resource Pools Summary"
441000000000049;"Datastores Summary";"Datastores Summary"
441000000000050;"Datastore Summary for VMs";"Datastore Summary for VMs"
441000000000051;"Datastore Summary for Hosts";"Datastore summary for Hosts"
441000000000052;"Datastore LUN Information";"Datastore LUN Information"
441000000000053;"Folder VMs Relationships";"Folder to VMs Relationships"
441000000000054;"Nodes By Capacity";"Nodes By Capacity"
441000000000055;"Nodes By CPU Usage";"Nodes By CPU Usage"
441000000000056;"Nodes By Memory Usage";"Nodes By Memory Usage"
441000000000057;"Recently Discovered Pods";"Recently Discovered Pods"
441000000000059;"Pods per Ready Status";"Pods per Ready Status"
441000000000060;"Summary - VMs migration ready";"Summary - VMs migration ready - no CD/DVD/Floppy connected"
441000000000061;"Summary - VMs NOT migration ready";"Summary - VMs NOT migration ready - CD/DVD/Floppy connected"
441000000000062;"Detailed - VMs migration ready";"Detailed - VMs migration ready - no CD/DVD/Floppy connected"
441000000000063;"Detailed - VMs NOT migration ready";"Detailed - VMs NOT migration ready - CD/DVD/Floppy connected"
441000000000064;"Registered VMs by Free Space";"Registered VMs by Free Space"
441000000000065;"Registered VMs with Free Space <35%";"Registered VMs with Free Space < 35%"
441000000000066;"Unregistered VMs Free Space <35%";"Unregistered VMs with Free Space < 35%"
441000000000067;"Online VMs (Powered On)";"Online VMs (Powered On)"
441000000000068;"VMs not Powered On";"VMs Not Powered On"
441000000000069;"Offline VMs Never Scanned";"Offline VMs Never Scanned"
441000000000070;"Offline VMs with Snapshot";"Offline VMs with Snapshots"
441000000000071;"VMs without VMware tools";"VMs without VMware tools after SmartState Analysis"
441000000000072;"VMs with old VMware tools";"VMs with old VMware tools"
441000000000073;"VMware Tools Versions";"VMware Tools Versions"
441000000000074;"VMs with EVM Snapshots";"VMs with EVM Snapshots"
441000000000075;"VMs with Consolidate Helper Snapshots";"VMs with Consolidate Helper Snapshots"
441000000000076;"EVM Server UserID Usage Report";"EVM Server UserID Usage Report"
441000000000077;"EVM Server UserIDs Never Used";"EVM Server UserIDs Never Used"
441000000000078;"Cluster - DRS migrations";"Cluster - DRS migrations"
441000000000079;"VC Snapshot Events by User";"Summary of VC Snapshot Events by User"
441000000000080;"VMs with Volume Free Space >= 75%";"VMs with Volume Free Space >= 75% (sorted by Datastore)"
441000000000081;"VMs with disk free space > 5GB";"VMs with disk free space > 5GB (sorted by disk free space)"
441000000000082;"VM Uptime - longest running";"VM Uptime (based on last boot, sorted by VM uptime)"
441000000000083;"VMs Powered Off registered to a Host";"VMs Powered Off but registered to Host (sorted by boot time)"
441000000000084;"VMs pending Retirement";"VMs that are pending Retirement"
441000000000085;"VMs that are Retired";"VMs that have been Retired (past retirement date)"
441000000000086;"VMs with invalid allocation of RAM";"VMs with invalid allocation of RAM (32-bit > 4GB allocated)"
441000000000087;"Summary of VM Create and Deletes";"Summary of VM Create and Deletes"
441000000000088;"VM Relationships";"VM Relationships"
441000000000089;"Folder to VMs Relationships";"Folder to VMs Relationships"
441000000000090;"Cluster Relationships";"Cluster Relationships"
441000000000091;"Operations VMs Powered On/Off for Last Week";"Operations VM Power On/Off Events for Last Week"
441000000000092;"Events for VM prod_webserver";"Summary of all VC Events for VM prod_webserver"
441000000000112;"Cluster memory trend  6 months";"Cluster memory trend based on past 6 months"
441000000000093;"Reconfigure Events by Department";"All Reconfigure Events for Department Classified VMs"
441000000000094;"VC Events initiated by username EVM86";"Virtual Center Events initiated by username EVM"
441000000000095;"Policy Events for Last Week";"Policy Events for Last Week"
441000000000096;"Policy Events2 for Last Week";"Policy Events2 for Last Week"
441000000000097;"Host CPU Usage per VM";"Host CPU Usage per VM"
441000000000098;"VM Performance - daily over last week";"VM Performance - daily averages for last week"
441000000000099;"VMs with Max Daily Mem > 50%  (past mo.)";"VMs with Maximum Daily Memory Burst > 50% over past month"
441000000000100;"VMs with Avg Daily Mem < 50% (past mo.)";"VMs with Average Daily Memory Usage < 50% over last month"
441000000000101;"VMs with Avg Daily CPU > 85% (past mo.)";"VMs with Average Daily CPU Usage > 85% over last month"
441000000000102;"VMs with Max Daily CPU > 85% (past mo.)";"VMs with Maximum Daily CPU Usage > 85% over last month"
441000000000103;"VMs with Avg Daily Mem > 95% (past mo.)";"VMs with Average Daily Memory Usage > 95% over last month"
441000000000104;"All Departments with Performance";"All Departments with Performance for last week"
441000000000113;"Cluster CPU Trends (last week)";"Cluster CPU Utilization trends (last week)"
441000000000105;"Top CPU Consumers (weekly)";"Top CPU Consumers (weekly)"
441000000000106;"Top Memory Consumers (weekly)";"Top Memory Consumers (weekly)"
441000000000107;"Top Storage Consumers";"Top Storage Consumers"
441000000000108;"VM Resource Utilization";"VM Resource Utilization"
441000000000109;"Weekly Utilization Overview";"Weekly Utilization Overview"
441000000000110;"Cluster Memory and CPU Usage (7 days)";"Cluster Memory and CPU usage over last 7 days"
441000000000111;"Processes for prod VMs sort by CPU Time";"Processes for prod VMs sorted by CPU Time"
441000000000114;"Cluster I/O Trends (last week)";"Cluster I/O Utilization Trends (last week)"
441000000000115;"Cluster Memory Trends (last week)";"Cluster Memory Utilization Trends (last week)"
441000000000116;"Datastore Capacity Trend over 6 mos.";"Datastore Capacity Trend over the last 6 months"
441000000000117;"Host Peak CPU Used Trend over 6 mos.";"Host Peak CPU Used Trends over last 6 Months"
441000000000118;"Host Peak Memory Used Trends for 6 Mos.";"Host Peak Memory Used Trends over last 6 Months"
441000000000119;"Host CPU Trends (last week)";"Host CPU Utilization trends (last week)"
441000000000120;"Host I/O Trends (last week)";"Host I/O Utilization Trends (last week)"
441000000000121;"Host Memory Trends (last week)";"Host Memory Utilization Trends (last week)"
441000000000122;"Provisioning Activity - by Approver";"Provisioning Activity - by Approver"
441000000000127;"Hosts: Compare Template";"Host Compare Template"
441000000000123;"Provisioning Activity - by Datastore";"Provisioning Activity - by Datastore"
441000000000124;"Provisioning Activity - by Requester";"Provisioning Activity - by Requester"
441000000000125;"Provisioning Activity - by VM";"Provisioning Activity - by VM Approved Date"
=====
Comment 3 Joe Rafaniello 2015-11-20 11:00:01 EST

*** This bug has been marked as a duplicate of bug 1279603 ***

Note You need to log in before you can comment on or make changes to this bug.