Bug 1279610 - [RFE] Support configuration of default subnet pools
[RFE] Support configuration of default subnet pools
Status: CLOSED DUPLICATE of bug 1311746
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 11.0 (Ocata)
Assigned To: Jiri Stransky
Arik Chernetsky
: FutureFeature
Depends On: 1269657
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 15:55 EST by Brent Eagles
Modified: 2018-03-19 06:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1269657
Environment:
Last Closed: 2018-03-19 06:51:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Eagles 2015-11-09 15:55:07 EST
+++ This bug was initially created as a clone of Bug #1269657 +++

Add support for default address pool configuration

# Default Subnet Pool to be used for IPv4 subnet-allocation.
# Specifies by UUID the pool to be used in case of subnet-create being called
# without a subnet-pool ID.  The default of None means that no pool will be
# used unless passed explicitly to subnet create.  If no pool is used, then a
# CIDR must be passed to create a subnet and that subnet will not be allocated
# from any pool; it will be considered part of the tenant's private address
# space.
# default_ipv4_subnet_pool =
 
# Default Subnet Pool to be used for IPv6 subnet-allocation.
# Specifies by UUID the pool to be used in case of subnet-create being
# called without a subnet-pool ID.  Set to "prefix_delegation"
# to enable IPv6 Prefix Delegation in a PD-capable environment.
# See the description for default_ipv4_subnet_pool for more information.
# default_ipv6_subnet_pool =
Comment 4 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Dmitry Tantsur 2016-12-12 10:28:11 EST
Is this request about undercloud or overcloud? I assume the latter.
Comment 7 Nir Yechiel 2018-03-19 06:51:57 EDT

*** This bug has been marked as a duplicate of bug 1311746 ***

Note You need to log in before you can comment on or make changes to this bug.