Bug 1279623 - Installing Shinken creates /etc/tmpfiles.d directory.
Installing Shinken creates /etc/tmpfiles.d directory.
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: shinken (Show other bugs)
el6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Hannequin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 16:28 EST by Matt Pusateri
Modified: 2016-03-20 15:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Centos 6.7
Last Closed: 2016-03-20 15:30:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Pusateri 2015-11-09 16:28:23 EST
Description of problem:

Installing Shinken puts shinken.conf file in folder /etc/tmpfiles.d/ instead of /etc/shinken/ where it's probably expected. 

Version-Release number of selected component (if applicable):
shinken.noarch                    2.4.2-1.el6               @epel

How reproducible:



Steps to Reproduce:
1. Install EPEL Repo 
2. yum install shinken
3.

Actual results:
[root@monitor01 etc]# ls -l /etc/tmpfiles.d/
total 4
-rw-r--r--. 1 root root 39 Oct  3 19:28 shinken.conf

Expected results:

Should not create /etc/tmpfiles.d directory should create /etc/shinken directory.

Additional info:
Comment 1 Matt Pusateri 2015-11-09 16:35:27 EST
Upon further inspection it looks like even the shinken.conf file either shouldn't have been created or it's wrong:

[root@monitor01 etc]# cat /etc/tmpfiles.d/shinken.conf
d /var/run/shinken   710 nagios nagios
Comment 2 David Hannequin 2016-03-20 15:30:50 EDT
Hi,

I test on centos 6 with shinken version 2.4.2-3 and directory /var/run/shinken is create.

Best regard

Note You need to log in before you can comment on or make changes to this bug.