Bug 1279644 - volume info of %s obtained from %s: ambiguous uuid - Starting geo-rep session
volume info of %s obtained from %s: ambiguous uuid - Starting geo-rep session
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.6
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Aravinda VK
:
Depends On:
Blocks: glusterfs-3.7.7 1279921
  Show dependency treegraph
 
Reported: 2015-11-09 18:09 EST by Tim Brammer
Modified: 2016-04-19 03:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279921 (view as bug list)
Environment:
Last Closed: 2016-02-15 01:27:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
volume.xml (1.67 KB, application/xml)
2015-11-10 11:09 EST, Tim Brammer
no flags Details
remote.xml (1.13 KB, application/xml)
2015-11-10 11:09 EST, Tim Brammer
no flags Details

  None (edit)
Description Tim Brammer 2015-11-09 18:09:21 EST
Description of problem:

When starting a geo-replication session with gluster volume geo-replication <master_volume> <slave_host>::<slave_volume> start The command returns as successful, but when running gluster volume geo-replication <master_volume> <slave_host>::<slave_volume> status the status remains as created, and no data is synchronized.

Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1. gluster system:: execute gsec_create
2. gluster volume geo-replication <master_volume> <slave_host>::<slave_volume> create push-pem
3. gluster volume geo-replication <master_volume> <slave_host>::<slave_volume> start
4. gluster volume geo-replication <master_volume> <slave_host>::<slave_volume> status

Actual results:

Status only shows "CREATED" and /var/log/glusterfs/geo-replication/<vol>/ log shows: 

[2015-11-09 17:59:37.783683] E [syncdutils(monitor):247:log_raise_exception] <top>: volume info of %s obtained from %s: ambiguous uuid
[2015-11-09 17:59:37.784065] I [syncdutils(monitor):220:finalize] <top>: exiting.

Expected results:

geo-sync session started.

Additional info:
Comment 1 Aravinda VK 2015-11-10 07:24:15 EST
Looks like some issue in Gluster Volume info. Please provide the output of

gluster volume info <master_volume>
gluster volume info <master_volume> --xml
gluster volume info <slave_volume> --remote-host=<slave_host>
gluster volume info <slave_volume> --remote-host=<slave_host> --xml
Comment 2 Tim Brammer 2015-11-10 11:00:31 EST
gluster volume info zpush

Volume Name: volume
Type: Replicate
Volume ID: e535d9ca-5b30-47fb-8578-d7e46d7ae02b
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: server1.com:/mnt/data/volume
Brick2: server1.com:/mnt/data/volume
Options Reconfigured:
changelog.changelog: on
geo-replication.ignore-pid-check: on
geo-replication.indexing: on
performance.readdir-ahead: on

gluster volume info remotevolume --remote-host=server3.com

Volume Name: remotevolume
Type: Distribute
Volume ID: e13dd525-be8a-49e4-addb-9cf7727b4364
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: server3.com:/mnt/data/volume
Options Reconfigured:
performance.readdir-ahead: on
Comment 3 Tim Brammer 2015-11-10 11:09 EST
Created attachment 1092349 [details]
volume.xml
Comment 4 Tim Brammer 2015-11-10 11:09 EST
Created attachment 1092350 [details]
remote.xml
Comment 5 Vijay Bellur 2015-11-23 23:00:28 EST
REVIEW: http://review.gluster.org/12724 (geo-rep: Fix syntax errors in GsyncdError) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 6 Vijay Bellur 2015-11-24 02:48:44 EST
REVIEW: http://review.gluster.org/12724 (geo-rep: Fix syntax errors in GsyncdError) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 7 Vijay Bellur 2016-01-04 01:35:14 EST
COMMIT: http://review.gluster.org/12724 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit a176d2420f3a0242ab0edab9e43be6621baa4f47
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Nov 10 18:46:28 2015 +0530

    geo-rep: Fix syntax errors in GsyncdError
    
    %s was not replaced by actual values in GsyncdError
    
    BUG: 1279644
    Change-Id: I3c0a10f07383ca72844a46f930b4aa3d3c29f568
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12566
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
     (cherry picked from commit 74699ddd777f7e862991cf3afad91823d30e5b84)
    Reviewed-on: http://review.gluster.org/12724
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 8 Kaushal 2016-04-19 03:47:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.