Bug 1279649 - Director Update 7.0 to 7.1: update fails on HA deployment with network isolation
Director Update 7.0 to 7.1: update fails on HA deployment with network isolation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: y2
: 7.0 (Kilo)
Assigned To: Jiri Stransky
Marius Cornea
: TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 18:32 EST by Marius Cornea
Modified: 2015-12-21 11:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to various issues with updating the Overcloud heat stack, updates from 7.0 to 7.1 with network isolation would not work. This fix corrects these issues. Now you can update deployments from 7.0 to 7.2 directly. Updates from 7.0 to 7.1 should be skipped. Ensure to to follow the documented update procedure, as additional Heat environment files are needed depending on the configuration of particular deployments.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:57:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployment error (23.08 KB, text/plain)
2015-11-09 18:32 EST, Marius Cornea
no flags Details
controller0 sosreport (14.11 MB, application/x-xz)
2015-11-09 18:34 EST, Marius Cornea
no flags Details
controller1 sosreport (13.98 MB, application/x-xz)
2015-11-09 18:37 EST, Marius Cornea
no flags Details
controller2 sosreport (13.55 MB, application/x-xz)
2015-11-09 18:38 EST, Marius Cornea
no flags Details
compute0 sosreport (6.81 MB, application/x-xz)
2015-11-09 18:40 EST, Marius Cornea
no flags Details
update.yaml (2.23 KB, text/plain)
2015-11-09 18:58 EST, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-11-09 18:32:05 EST
Created attachment 1091995 [details]
deployment error

Description of problem:
Updating from 7.0 to 7.1 fails on HA deployment(3 x ctrls + 1 x compute) with network isolation.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy 7.0
openstack overcloud deploy --templates ~/templates-7.0/my-overcloud -e ~/templates-7.0/my-overcloud/environments/network-isolation.yaml -e ~/templates-7.0/network-environment.yaml  --control-scale 3 --compute-scale 1 --ntp-server clock.redhat.com --libvirt-type qemu

2. Update undercloud to 7.1

3. Update stack
openstack overcloud update stack overcloud -i --templates ~/templates-7.1/my-overcloud -e ~/templates-7.1/my-overcloud/overcloud-resource-registry-puppet.yaml -e ~/templates-7.1/my-overcloud/environments/network-isolation.yaml -e ~/templates-7.1/network-environment.yaml  -e ~/templates-7.1/update.yaml

Actual results:
Update fails.

Expected results:
Update succeeds. 

Additional info:
Attaching the error in the deployment show and sosreports from the overcloud nodes.
Comment 2 Marius Cornea 2015-11-09 18:34 EST
Created attachment 1091996 [details]
controller0 sosreport
Comment 3 Marius Cornea 2015-11-09 18:37 EST
Created attachment 1091997 [details]
controller1 sosreport
Comment 4 Marius Cornea 2015-11-09 18:38 EST
Created attachment 1091998 [details]
controller2 sosreport
Comment 5 Marius Cornea 2015-11-09 18:40 EST
Created attachment 1091999 [details]
compute0 sosreport
Comment 6 Marius Cornea 2015-11-09 18:58 EST
Created attachment 1092017 [details]
update.yaml
Comment 7 Marius Cornea 2015-11-11 12:24:25 EST
This looks similar to the initial report in BZ#1272347 (services are restarted via systemd) but the update.yaml contains the workaround and it still failed( https://bugzilla.redhat.com/show_bug.cgi?id=1272347#c7 )
Comment 9 Amit Ugol 2015-12-10 01:29:24 EST
7.0 upgrade to 7.2 works, 7.0 to 7.1 won't be supported.
is this bug valid still?
Comment 10 Jiri Stransky 2015-12-10 07:45:31 EST
I think the bug is valid (7.0 to 7.1 has issues). The issues are addressed in 7.2, so the fix for this bug is to upgrade 7.0 to 7.2 directly (following the documented procedure) instead of attempting 7.0 to 7.1. So if 7.0 to 7.2 with network isolation works, i'd consider this fixed.
Comment 12 Marius Cornea 2015-12-12 19:39:08 EST
Got a passed update from 7.0 to 7.2 with 3 controllers, 1 compute and 3 ceph nodes by using network isolation.
Comment 14 errata-xmlrpc 2015-12-21 11:57:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.