Bug 1279704 - python-os-testr script should not be in both subpackages
python-os-testr script should not be in both subpackages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-os-testr (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chandan Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 00:01 EST by Toshio Ernie Kuratomi
Modified: 2015-11-14 12:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-14 12:58:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2015-11-10 00:01:31 EST
Description of problem:
The python-os-testr package contains a subpackage for python2 and python3.  The python2 subpackage contains scripts which need python3.  This causes several problems:

* Python2 packages shouldn't require python3 and vice versa.
* The scripts which need python3 are broken without manual intervention since under python3, the scripts won't be able to find their required libraries (as the needed deps are not installed).

The Fedora Packaging Guidelines specify how to fix this situation:
https://fedoraproject.org/wiki/Packaging:Python#Avoiding_collisions_between_the_python_2_and_python_3_stacks

After a bit of testing of this package, I believe that the package does not need a separate version of the scripts for python2 and python3 but I'm not intimately familiar with it so I could be wrong.  I've created a patch for the spec file that will remove the extraneous version of the script (and also fix a stray shebang that creates a false dep on python2 in the python3 package).

Please apply the patch and build a new version of the package if the script does not need to be specific to the python version.  If the scripts do need to exist in separate versions for each python version, please take a look at how the guidelines tell you to create separately named scripts for each version or, if you need help, feel free to reach out to me or another packager familiar with python3 packaging in Fedora (there's many of us in the #fedora-python irc channel on irc.freenode.net.  I'm abadger1999 there).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Toshio Ernie Kuratomi 2015-11-10 00:04:58 EST
Scratch build with that patch: http://koji.fedoraproject.org/koji/taskinfo?taskID=11763872
Comment 2 Chandan Kumar 2015-11-14 12:09:47 EST
Hi Toshio,

Thanks for the patch,

I have applied the patch and created a new build: http://koji.fedoraproject.org/koji/buildinfo?buildID=699296

Thanks,

Chandan Kumar
Comment 3 Toshio Ernie Kuratomi 2015-11-14 12:58:28 EST
Excellent.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.