Bug 1279733 - The upgrade should abort at the beginning if the deployment_type is enterprise
The upgrade should abort at the beginning if the deployment_type is enterprise
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 02:27 EST by Anping Li
Modified: 2015-11-19 18:29 EST (History)
4 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.9-1.git.0.9f97293.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:29:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2015-11-10 02:27:43 EST
Description of problem:

if user make a mistake and still keep the deployment_type=enterprise in inventory, and then upgrade to v 3.1. It will fail at the tasks which read the 'openshift.common.service_type'. 
It is better to abort the upgrade at the beginning.


Version-Release number of selected component (if applicable):
openshift-ansible-playbooks-3.0.7-1.git.156.70ed54c.el7aos.noarch


How reproducible:
always

Steps to Reproduce:
1. yum install atomic-openshift-utils-3.0.7-1
2. ansible-playbook -i config/host3020cluster //usr/share/ansible/openshift-ansible/playbooks/adhoc/upgrades/upgrade.yml

Actual results:
TASK: [openshift_master_cluster | Add the cluster master service resource] **** 
failed: [master1.example.com] => {"changed": true, "cmd": ["pcs", "resource", "create", "master", "systemd:openshift-master", "op", "start", "timeout=90s", "stop", "timeout=90s", "--group", "openshift-master"], "delta": "0:00:00.122610", "end": "2015-11-10 14:48:23.781428", "rc": 1, "start": "2015-11-10 14:48:23.658818", "warnings": []}
stderr: Error: Unable to create resource 'systemd:openshift-master', it is not installed on this system (use --force to override)

FATAL: all hosts have already failed -- aborting


Expected results:

if the deployment_type isn't match to the target version, the upgrade should abort at the beginning. The upgrade tools should have some check functionality at the beginning of upgrade.

Additional info:
Comment 4 Anping Li 2015-11-11 08:14:09 EST
There is no upgrade.yaml in your pkgs.  will verify it when you pushed in to puddle.
Comment 5 Jason DeTiberus 2015-11-11 11:04:10 EST
My apologies, the upgrade.yml file is moved with the PR (which will be included in today's puddle).

The new location for running it is playbooks/byo/openshift-cluster/upgrades/v3_0_to_v3_1/upgrade.yml
Comment 7 Anping Li 2015-11-12 01:52:25 EST
I can get the expected message when using byo/openshift-cluster/upgrades/v3_0_to_v3_1/upgrade.yml. So move bug to verified.

TASK: [fail ] ***************************************************************** 
failed: [10.3.8.193] => {"failed": true}
msg: This upgrade is only supported for origin and openshift-enterprise deployment types


FATAL: all hosts have already failed -- aborting
Comment 9 errata-xmlrpc 2015-11-19 18:29:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:2492

Note You need to log in before you can comment on or make changes to this bug.