Bug 1279735 - With Keystone V3 Apis the dashboard urls need to get updated so the rc file downloaded is correct
With Keystone V3 Apis the dashboard urls need to get updated so the rc file d...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity low
: ga
: 9.0 (Mitaka)
Assigned To: Radomir Dopieralski
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 02:33 EST by Ruchika K
Modified: 2016-08-11 08:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-9.0.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:13:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruchika K 2015-11-10 02:33:21 EST
Description of problem:

While using Keystone V3,
the identity url still has this format. i.e. has a api version of 2.0 displayed.
 < >/v2.0. If LDAP is used with this, this does not hurt bulk of the functionality.

Problems appear as soon as a user downloads the "rc" file from the dashboard.  Since the rc  has the wrong url information, it is not usable by the user.

So basically the advertised API links here need to be updated.


Version-Release number of selected component (if applicable):
openstack 7.1

How reproducible:

100%

Steps to Reproduce:
1. Install Keystone V3
2. View the urls on horizon 
3. Download the rc file and try to use it.

Actual results:


Expected results:


Additional info:
Comment 3 Adam Young 2016-03-19 18:41:56 EDT
This is a change to Horizon, not in Keystone.
Comment 4 Matthias Runge 2016-03-30 05:10:13 EDT
There was a commit for mitaka: https://github.com/openstack/horizon/commit/46a739531f9c2eb55c65000eca6b5737b16145ab

Unfortunately, it's not backportable, there are changed strings, thus translations will break.
Comment 5 Matthias Runge 2016-05-18 07:59:52 EDT
This is fixed in mitaka.
Comment 8 Ido Ovadia 2016-07-31 11:17:22 EDT
Verified
========
python-django-horizon-9.0.1-1.el7ost.noarch
Comment 10 errata-xmlrpc 2016-08-11 08:13:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.