Bug 1279736 - The v1beta3 wasn't removed from master-config.yaml
The v1beta3 wasn't removed from master-config.yaml
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 02:33 EST by Anping Li
Modified: 2015-11-19 18:29 EST (History)
6 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.9-1.git.0.9f97293.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:29:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2015-11-10 02:33:57 EST
Description of problem:
The v1beta3  is in master-config.yaml after upgrade. As design 'support for the v1beta3 api was removed in 3.1.  /etc/origin/master/master-config.yml cannot have it listed as one of the `apiLevels`, it should be removed from master-config.yaml 


Version-Release number of selected component (if applicable):
openshift-ansible-playbooks-3.0.7-1.git.156.70ed54c.el7aos.noarch

How reproducible:
always

Steps to Reproduce:
1. upgrade from v3.0.2 to v3.1
2. check the api level in master-config.yaml after upgrade


Actual results:
# head master-config.yaml 
apiLevels:
- v1beta3
- v1
apiVersion: v1
assetConfig:
  logoutURL: ""
  masterPublicURL: https://openshift-120.lab.sjc.redhat.com:8443
  publicURL: https://openshift-120.lab.sjc.redhat.com:8443/console/


Expected results:
The api level support for the v1beta3 should be removed.

Additional info:
Comment 1 Jason DeTiberus 2015-11-10 17:38:11 EST
I'm not able to duplicate this? Did you verify that the 3.1 repo was available and the deployment_type was set to openshift_enterprise? Otherwise only a 3.0 minor upgrade would be performed.

Any additional information that you could provide related to how the upgrade was performed (installer wrapper vs ansible directly, configuration files, etc) would help troubleshoot the problem.
Comment 4 Anping Li 2015-11-12 03:20:54 EST
Verified and pass. the v1beta3 was removed from master-config.yml
Comment 6 errata-xmlrpc 2015-11-19 18:29:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:2492

Note You need to log in before you can comment on or make changes to this bug.