Bug 1279771 - [Host QoS] - Updating/changing value/s on the Host QoS entity via DC while a network that using this entity and attached to server doesn't invoke sync
[Host QoS] - Updating/changing value/s on the Host QoS entity via DC while a ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
x86_64 Linux
medium Severity medium (vote)
: ovirt-4.1.0-beta
: 4.1.0.2
Assigned To: Martin Mucha
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 04:26 EST by Michael Burman
Modified: 2017-02-01 09:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:49:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52952 master MERGED core: Update of HostNetworkQos on DataCenter must trigger update of network 2016-04-21 03:09 EDT
oVirt gerrit 53080 ovirt-engine-3.6 ABANDONED core: Update of HostNetworkQos on DataCenter must trigger update of network 2016-02-05 02:45 EST
oVirt gerrit 59310 master MERGED core: after HostNetworkQos is removed, sync influenced networks. 2016-07-19 05:59 EDT

  None (edit)
Description Michael Burman 2015-11-10 04:26:34 EST
Description of problem:
[Host QoS] - Updating/changing value/s on the Host QoS entity via DC while a network that using this entity and attached to server doesn't invoke sync, cause setup networks command is not sent. 

Version-Release number of selected component (if applicable):
3.6.0.3-0.1.el6

How reproducible:
100

Steps to Reproduce:
1. Create Host QoS entity(weight - 50, rate - 500, commit - 300) via DC or via Networks tab while creating new network.
2. Attach the network with the QoS to host via Setup networks
3. Via DC, update/change the weight value to 50 on the Host QoS entity 

Actual results:
Network considered as out-of-sync. Setup networks command isn't sent and doesn't invoke sync. There is a difference between Host and DC.

Expected results:
Setup Networks command should be sent and network should be synced to host.
Comment 1 Dan Kenigsberg 2015-11-10 08:39:15 EST
alkaplan told me that Engine simply does not issue a multihost command on this change (unlike what happens when MTU is changed in the DC level).

This should be fixed (but not necessarily during 3.6.z).
Comment 2 Michael Burman 2015-11-23 06:51:57 EST
Martin,

Please note, that the fix for this bug should include scenario in which we removing a Host QoS entity from DC while network/s attached to host/s are using this QoS entity ^^ (As agreed with danken) .

For QA, to test such scenario. 

Thanks,
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-30 17:37:38 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Mike McCune 2016-03-28 19:09:17 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Michael Burman 2016-05-25 08:09:55 EDT
Tested on - 4.0.0-0.0.master.20160524171531.gitfba61e9.el7.centos and 
vdsm-4.18.0-43.git6f7fc83.el7.centos.x86_64

- Updating/changing values on the host QoS entity via DC while the network attached to host is working and invoking sync.

- Remove the host QoS entity from DC while the network is attached to the host isn't invoke sync and didn't fixed as agreed, see comment 2^^ 
Dan, do you want separate bug on that scenarion or should we keep going on this one? 

Thanks,
Comment 6 Michael Burman 2016-05-26 01:15:05 EDT
Martin, please fix and include the remove host QoS from DC scenario as well in this BZ. Thank you.
Comment 7 Red Hat Bugzilla Rules Engine 2016-05-26 01:15:11 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Michael Burman 2016-12-05 08:02:07 EST
Verified on - 4.1.0-0.2.master.20161204231323.gite9669ad.el7.centos

Note You need to log in before you can comment on or make changes to this bug.