Bug 1279782 - Version history table paging broken
Version history table paging broken
Status: CLOSED DUPLICATE of bug 1273036
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Toni Rikkola
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 04:58 EST by Jiri Locker
Modified: 2015-11-10 07:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 07:08:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2015-11-10 04:58:36 EST
Description of problem:
When asset has 6 or more revisions (commits), the table paging becomes effective. The first page is limited to 5 revisions, however the second page is empty. It remains empty until there is 11+ revisions. Then first page has five latest revision, the other five revisions are skipped and the second (last) page contains remaining revisions.

It seems that paging starts working correctly when there is more than 20 revisions.

Version-Release number of selected component (if applicable):
6.2.0.ER5

How reproducible:
-

Steps to Reproduce:
1. Create new DRL file, save it 5 times to reach 6 revisions.
2. Switch to overview, table paginator says 1-5 of 6.
3. Move to next page.

Actual results:
The second page is empty, paginator says 11 of 6.

Expected results:
The second page should contain 1 row with the initial commit, paginator should say 6 of 6.
OR, similar result if the page limit changes with the fix (e.g. to 10).

Additional info:
Comment 1 Toni Rikkola 2015-11-10 07:08:28 EST

*** This bug has been marked as a duplicate of bug 1273036 ***

Note You need to log in before you can comment on or make changes to this bug.