Bug 1279784 - System upgrade resets SElinux settings
System upgrade resets SElinux settings
Status: CLOSED DUPLICATE of bug 1279621
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 05:05 EST by Illya
Modified: 2015-11-12 04:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 04:59:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Illya 2015-11-10 05:05:32 EST
Description of problem:
Upgrade from Fedora 22 to Fedora 23 with dnf-plugin-system-upgrade caused some SELinux settings to be changed to default.

Hier example with nginx. But the same situation is with pdns (pdns_can_network_connect_db)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install nginx on Fedora 22
2. Allow network connection to DB (setsebool -P httpd_can_network_connect_db 1)
3. Upgrade system as described hier: https://fedoraproject.org/wiki/DNF_system_upgrade

Actual results:
Nginx cannot connect DB:

getsebool httpd_can_network_connect_db
httpd_can_network_connect_db --> off



Expected results:
DB connection from web server still works after upgrade

Additional info:
Comment 1 Will Woods 2015-11-11 10:42:48 EST
As it says in the man page:

       Similarly, problems encountered on your system after the  upgrade  com‐
       pletes  should  be  reported  to the maintainers of the affected compo‐
       nents.  In other words: if (for example) KDE stops working,  it's  best
       if you report that to the KDE maintainers.

This is an SELinux policy problem, so I'm reassigning to selinux-policy.
Comment 2 Miroslav Grepl 2015-11-12 04:59:44 EST

*** This bug has been marked as a duplicate of bug 1279621 ***

Note You need to log in before you can comment on or make changes to this bug.