Bug 1279797 - Hard freezes and/or garbled image occur when using high resolution docking station display outputs (Lenovo T440s/i7-4600U,
Hard freezes and/or garbled image occur when using high resolution docking st...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lyude
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 05:42 EST by David Jaša
Modified: 2016-11-10 02:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 02:09:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2015-11-10 05:42:07 EST
Description of problem:
Hard freezes and/or garbled image occur when using high resolution docking station display outputs. Hardware tested is:
  * Thinkpad T440s with i7-4600U CPU/GPU
  * Corresponding Ultra Dock with latest firmware
  * Lenovo ThinkVision 2840 4k screen in single monitor or PBP mode

According to Intel specs for the CPU, maximum resolution is 3200x2000 @ 60 Hz. However, resolutions beyond this bound are offered by xrandr as well and in case of embedded mini Display Port, they also work. The docking station outputs offer the same higher resolution but attempts to use them result in garbled image to hard freezes (no response to even network or sysrq). The detailed info about I/O involved is:

Laptop (:
mini Display Port (DP1)

Dock (Ultra Dock 40A2):
output 1 (DP2-1): HDMI or DP
output 2 (DP2-2): DVI or DP

Monitor:
  * mDP, DP, HDMI: can carry all resolutions each (up to 3840x2160@60)
  * MHL: essentially second HDMI, limited to 1920x1080@30 or 1080i
  * can be configured to pretend to be two <= 1920x2160 monitors (using
      HDMI and one of DP inputs)
full doc & specs: https://support.lenovo.com/za/en/docs/UM100200


Version-Release number of selected component (if applicable):
3.10.0-327.el7.x86_64
xorg-x11-drv-qxl-0.1.1-18.el7.x86_64

How reproducible:
always


Steps to Reproduce:
1 connect monitor to dock output using HDMI and/or Display port, set
    3840x2160@30 resolution
2. PBP mode:
    * configure monitor: enable PBP an chose inputs for respective halves
    * connect the monitor inputs to dock outputs
    * enable outputs at low resolution, gradually enlarge resolution
3. PBP mode: enable output(s) at 1920x2160 right away


Actual results:
1. either hard freeze or no data to monitor ("power saving mode")
2. once resolution exceeds 2160 vertical pixes, screen shows garbage
3. hard freeze
* hard freezes when shuffling outputs etc...

Expected results:
* freezes never occur - if mode fails, output is reverted to previous, or xrandr doesn't offer unavailable resolutions (e.g. 3840x2160@60 over single output)
* PBP mode works at full frequency

Additional info:
Comment 4 Lyude 2016-03-30 12:06:43 EDT
This is an issue caused by Haswell's inability to actually drive displays at 4K with a refresh rate of 60Hz even if it thinks it can. While you might be thinking "but Haswell isn't THAT old, surely this must be a mistake" unfortunately I've confirmed this with multiple developers from Intel after running into issues with this myself. This being said, while we can't run 4K at 60Hz we can do it at 30Hz. Luckily there happens to be a few WIP fixes upstream for doing this in i915.

Note You need to log in before you can comment on or make changes to this bug.