Bug 1279812 - Pluggable panels, dashboards
Pluggable panels, dashboards
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Matthias Runge
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 06:44 EST by Matthias Runge
Modified: 2016-04-07 17:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-8.0.0-5.el7ost
Doc Type: Enhancement
Doc Text:
With this release, panels are configurable. You can add or remove panels by using configuration snippets. For example, to remove the "Resource panel": * Place a file in '/usr/share/openstack-dashboard/openstack_dashboard/local/enabled'. * Name that file '_99_disable_metering_dashboard.py'. * Copy the following content into the file: # The slug of the panel to be added to HORIZON_CONFIG. Required. PANEL = 'metering' # The slug of the dashboard the PANEL associated with. Required. PANEL_DASHBOARD = 'admin' # The slug of the panel group the PANEL is associated with. PANEL_GROUP = 'admin' REMOVE_PANEL = True * Restart the Dashboard httpd service: # systemctl restart httpd For more information, see the Pluggable Dashboard Settings section in the Configuration Reference Guide in the Red Hat OpenStack Platform Documentation Suite available at: https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:11:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2015-11-10 06:44:57 EST
Description of problem:
Liberty release introduced more pluggable settings, panels and dashboards.

This is mostly to document the new features.
Comment 3 Matthias Runge 2016-01-26 03:15:05 EST
There is nothing to test here.
Comment 4 Ido Ovadia 2016-01-31 10:20:33 EST
Verified
========
python-django-horizon-8.0.0-10.el7ost.noarch
Comment 6 errata-xmlrpc 2016-04-07 17:11:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.