Bug 1279836 - Fails to build twice in a row
Fails to build twice in a row
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
mainline
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks: 1279345
  Show dependency treegraph
 
Reported: 2015-11-10 07:17 EST by Niels de Vos
Modified: 2016-06-16 09:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279345
Environment:
Last Closed: 2016-06-16 09:43:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2015-11-10 07:17:01 EST
+++ This bug was initially created as a clone of Bug #1279345 +++
+++                                                           +++
+++                                                           +++
+++ Use this bug to provide a fix for mainline/master         +++

Hello,

glusterfs still fails to build twice in a row, because the source is touched, after a suc. build with make dist-clean:


dpkg-source: info: local changes detected, the modified files are:
 glusterfs-3.7.6/contrib/umountd/Makefile
 glusterfs-3.7.6/glusterfs-api.pc
 glusterfs-3.7.6/libgfchangelog.pc
 glusterfs-3.7.6/libgfdb.pc
 glusterfs-3.7.6/tests/env.rc


dpkg-source: info: building glusterfs using existing ./glusterfs_3.7.6.orig.tar.gz
dpkg-source: warning: ignoring deletion of file geo-replication/syncdaemon/configinterface.py, use --include-removal to override
dpkg-source: warning: ignoring deletion of file xlators/features/glupy/src/__init__.py, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/nsm-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/changelog-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/rpc-common-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/nlm4-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/glusterd1-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/portmap-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/rpc-common-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/acl3-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/mount3udp.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/glusterfs3-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/glusterfs3-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/nlm4-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/nsm-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/changelog-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/glusterd1-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/cli1-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/cli1-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/acl3-xdr.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/mount3udp.h, use --include-removal to override
dpkg-source: warning: ignoring deletion of file rpc/xdr/src/portmap-xdr.c, use --include-removal to override
dpkg-source: warning: ignoring deletion of file extras/glusterd.vol, use --include-removal to override
dpkg-source: warning: ignoring deletion of file extras/init.d/glusterd-SuSE, use --include-removal to override
dpkg-source: warning: ignoring deletion of file extras/init.d/glusterd.plist, use --include-removal to override
dpkg-source: warning: ignoring deletion of file extras/init.d/glusterd-Debian, use --include-removal to override
dpkg-source: warning: ignoring deletion of file extras/init.d/glusterd-Redhat, use --include-removal to override
dpkg-source: warning: ignoring deletion of file extras/init.d/glusterd-FreeBSD, use --include-removal to override
dpkg-source: warning: ignoring deletion of file tools/glusterfind/src/tool.conf, use --include-removal to override
Comment 1 Vijay Bellur 2015-11-13 14:19:13 EST
REVIEW: http://review.gluster.org/12579 (build: `make distclean` doesn't clean all it ought to, needs to) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2015-11-15 06:02:46 EST
COMMIT: http://review.gluster.org/12579 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit b7b13c73369a3cb237de16d58425b63640c6f33e
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Fri Nov 13 14:07:03 2015 -0500

    build: `make distclean` doesn't clean all it ought to, needs to
    
    Debian builds fail to "build twice in a row" due to left over files
    remaining after running `make distclean`
    
    The main culprits are files created from *.in files during ./configure.
    In particular these are ./glusterfs-api.pc, ./libgfchangelog.pc,
    ./libgfdb.pc, and ./tests/env.rc.
    
    The strange one is contrib/umountd/Makefile{,.in}. While these are
    created by ./configure - for reasons I don't quite fathom, perhaps
    because contrib/umountd is included in EXTRA_DIST - after that
    make and make distclean don't descend into the directory to build or
    clean it (because it's not needed for Linux, and not built.)
    
    Also removing the `find . -name Makefile -exec rm -f {}\;` from the
    gitclean target, it's not needed (redundant) as its prereq distclean
    target will have already removed them.
    
    Change-Id: Ifc45b71d852052ef4b92f356279ce2ba2bbc5bb6
    BUG: 1279836
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/12579
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Tested-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:43:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.