Bug 127989 - Checking the size of a partition which hasn't been allocated yet
Checking the size of a partition which hasn't been allocated yet
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-15 23:03 EDT by Andy Canfield
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-16 00:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Canfield 2004-07-15 23:03:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031224

Description of problem:
May be related to Bugzilla number 124017

The message:
-----------------------------------------------
An unhandled exception has occurred. This is
most likely a bug. Please copy the full text
of this exception or save the crash dump to a
floppy and then file a detailed bug report against
anaconda at http://bugzilla.redhat.com/bugzilla/
Traceback (most recent call last):
   File "/usr/bin/anaconda", line 1134, in ?
      intf.run(id,dispatch,configFileData)
   File "/usr/lib/anaconda/text.py", line 451,
in run
   rc = apply(win,(self.screen), )+args)
   File
"/usr/lib/anaconda/textw/partition_text.py",
   (errors,warnings) =
self.partitions.sanityCheckAllRequests,(self.disk
set)
   File "/usr/lib/anaconda/partitions.py", line
866, in sandityCheckAllRequests
   if req.getActualSize(elf,diskset) < size:
   File "/usr/lib/anaconda/partRequests.py",
line 454, in getActualSize
   raise Runtime Error, "Checking the size of a
partition which hasn't been allocated yet"
Runtime Error: Checking the size of a partition
   which hasn't been allocated yet.
------------------------------------------------------
I was installing LinuxTLE 5.5 on an ATEC computer.
We have a dozen such computers, all identical.
We have installed it successfully on seven other machines.
The hard disks are approximately 40 GB.

I suspect the problem is that on this hard disk a cylinder
is not an even number of megabytes. The hard disk is
approximately 40 gigabytes, but consists of 5005 cylinders.
I think that various disk partitioning programs
are trying for alignment, either megabyte or cylinder or track,
and it just isn't possible on this hardware.
The result is that Disk Druid shows gaps between the
partitions. Also, the installer complains about
inconsistant disk partitioning.

The OTHER machines were pre-partitioned as follows:
	/dev/hda1 = 2047 MB fat (MS-DOS 6.22)
	/dev/hda2 = extended partition, rest of the disk
With Disk Druid in the installer we created:
	/ = 10240 MB
	swap = 1024 MB
	/home = rest of the disk
On these other machines things went OK.

The problem machine was pre-partitioned with Windows 98:
	/dev/hda1 = 2 GB vfat (Windows 98)
	/dev/hda2 = extended paritition, rest of the disk
	/dev/hda5 = 2 GB vfat (Windows 98)
With Disk Druid in the installer I created:
	/ = 10240 MB
	swap = 1024 MB
	/home = rest of the disk
When I accepted the results from Disk Druid,
the crash occurred.

It is quite possible that the resulting
partition table would have looked like this:
	/dev/hda1 = C:
	gap
	/dev/hda2
		/dev/hda5 = D:
		gap
		/dev/hda6 = /
		gap
		/dev/hda7 = swap
		gap
		/dev/hda8 = /home
		gap
	gap
and that 12 entries are too many.

After the crash, I booted from the CD in rescue mode
and the partition table had not been altered; it still
showed /dev/hda1, /dev/hda2, and /dev/hda5 only.
So I used fdisk to create /dev/hda6 and /dev/hda7
and /dev/hda8 with no gaps between them.
Then I ran the installer gain, and with Disk Druid
used the existing partitions instead of trying to create
new ones, and it went OK. Here is the output of the
command 'sfdisk -l /dev/hda':

Disk /dev/hda: 5005 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1   *      0+    261     262-   2104483+   b  Win95 FAT32
/dev/hda2        262    5004    4743   38098147+   f  Win95 Ext'd (LBA)
/dev/hda3          0       -       0          0    0  Empty
/dev/hda4          0       -       0          0    0  Empty
/dev/hda5        262+    523     262-   2104483+   b  Win95 FAT32
/dev/hda6        524+   1829    1306-  10490413+  83  Linux
/dev/hda7       1830+   1960     131-   1052226   82  Linux swap
/dev/hda8       1961+   5004    3044-  24450898+  83  Linux

This computer has a known problem that the video card
has a bad graphics accelerator chip. So I was running
the installer in text mode ("linux text") rather than
in graphics mode. I believe that this was not the cause
of the problem.

The file /usr/sbin/anaconda has no version number
but it is copyright 1999-2003. I cannot find
"Disk Druid" on my computer so I can give you no
version information at all."

(PS - it took me ten times longer to report the bug
to Bugzilla than it did to bypass the bug.
Next time I won't bother reporting.)


Version-Release number of selected component (if applicable):
LinuxTLE 5.5 Anaconda

How reproducible:
Didn't try


Additional info:
Comment 1 Jeremy Katz 2004-07-16 00:56:33 EDT
You'll need to report this to the TLELinux people.  Unfortunately, I
don't know what changes they've made and thus it's not possible for me
to support problems with it.

Note You need to log in before you can comment on or make changes to this bug.