Bug 127990 - needs libgtkhtml-3.1.so.10, this is not available.
needs libgtkhtml-3.1.so.10, this is not available.
Product: Fedora
Classification: Fedora
Component: balsa (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Depends On:
  Show dependency treegraph
Reported: 2004-07-15 23:48 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-16 14:48:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-07-15 23:48:23 EDT
Description of problem:

  yum update balsa needs libgtkhtml-3.1.so.10

Version-Release number of selected component (if applicable):

  fresh - see below

How reproducible:

  Seems to have been a problem for the last few kernels.

Steps to Reproduce:
1.yum update balsa
Actual results:

[root@hoho2 root]# cat /proc/version
Linux version 2.6.7-1.488smp (bhcompile@daffy.perf.redhat.com) (gcc
version 3.4.1 20040702 (Red Hat Linux 3.4.1-2)) #1 SMP Wed Jul 14
10:02:03 EDT 2004

[root@hoho2 root]# date
Thu Jul 15 22:43:24 CDT 2004

[root@hoho2 root]# rpm -q balsa

[root@hoho2 root]# yum update balsa
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
....Unable to satisfy dependencies
Package balsa needs libgtkhtml-3.1.so.10, this is not available.
[root@hoho2 root]#

Expected results:

Additional info:
Comment 1 John Dennis 2004-07-16 11:49:22 EDT
Your yum says its updating from Fedora Core 2 but the balsa package
which has a dependency on libgtkhtml-3.1.so.10 is the one from fc3
which was built into fc3 yesterday and probably appeared in rawhide as
a consequence. The version of libgtkhtml that is being required is in fc3.

So I'm not quite sure what's up with your installation, are you trying
to update from rawhide? (Yum usually hardcodes the version it prints
so if you've set your baseurl to something else it wouldn't be visible
in your output) What baseurl are you updating from? 

We don't support doing yum updates from rawhide because its a moving
target and not a consistent, coherent package set that is self consistent.
Comment 2 Bob Gustafson 2004-07-16 14:11:13 EDT
I am actually doing a 'yum list' and then doing a 'yum install <name>'
from that list.  I seem to be getting the latest of what's available
with that process!

Yes, I see that yum prints Core 2. However, the 2 is not hard coded in
the /etc/yum.conf file. It comes from thin air somewhere.

I am doing a rolling install/update - not too concerned that things
don't work from time to time - but I do try to send out a bug report
when something looks odd.

I did an install from FC2, but have not yet done a fresh install from
FC3-test1. I figured that with my rolling update/install, I was at
least as far along as FC3-test1, but maybe not. Is there something I
should tweek somethere to make it FC3 ?

What do you mean by 'don't support doing yum updates from rawhide'
anyway? I am not expecting any active support - just that things keep
rolling along in a productive manner.

Comment 3 John Dennis 2004-07-16 14:48:25 EDT
In the file /etc/yum.conf there will be a section where you should see
a name labeled "Developement Tree" in that section will be a variable
labeled "baseurl" that's where you pulled this package from. Pulling
from the development tree is risky (unstable), you can't make any
assumptions what the state of that set of rpm's is, or whether all
their dependencies can be met from what's in that set since it's a
moving target. When we get ready to make a release we nail things down
so there are no inconsistencies. 

It's really not a bug to have an unmet dependency in a development
tree, it's probably more of a timing issue of when packages got moved
into the tree.
Comment 4 Leo 2004-07-21 21:29:11 EDT
I'm seeing the same thing after a fresh install of core 2 test 3.
[root@localhost root]# yum update
Gathering header information file(s) from server(s)
Server: Fedora Core 2.90 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
....Unable to satisfy dependencies
Package balsa needs libgtkhtml-3.1.so.10, this is not available.
Package gtkhtml3 needs libgtkhtml-3.1.so.10, this is not available.
[root@localhost root]# rpm -qa | grep gtkhtml
[root@localhost root]# cat /etc/yum.conf

#name=Fedora Core $releasever - $basearch - Base

#name=Fedora Core $releasever - $basearch - Released Updates

#name=Fedora Core $releasever - $basearch - Unreleased Updates

name=Fedora Core $releasever - Development Tree

Comment 5 Michael Young 2004-07-22 11:09:19 EDT
The original gtkhtml3 shipped with FC3t1 (3.1.16-3) provided
libgtkhtml-3.1.so.10, however there was an upgrade (3.1.17-3) which
provided libgtkhtml-3.1.so.11 (the version 3.1.18-1 on rawhide now is
just broken). So balsa should probably link against libgtkhtml-3.1.so.11.
Comment 6 John Dennis 2004-07-22 11:17:51 EDT
Thank you, yes I realize this. For reasons that elude me our build
system when locked produces these version skews because the package
links against what is in the locked version but still populates
rawhide from an unlocked version. I'm trying to get it resolved, it's
just an arcane build internal issue.

Note You need to log in before you can comment on or make changes to this bug.