Bug 1279901 - [Doc] Instruction wizard "Content Host Registration" is incomplete
[Doc] Instruction wizard "Content Host Registration" is incomplete
Status: CLOSED DUPLICATE of bug 1446374
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.1
Unspecified Unspecified
medium Severity medium (vote)
: GA
: 6.2
Assigned To: satellite-doc-list
satellite-doc-list
: Documentation
Depends On: 1279819
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 07:54 EST by Stephen Wadeley
Modified: 2017-06-13 01:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279819
Environment:
Last Closed: 2017-06-13 01:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Wadeley 2015-11-10 07:54:53 EST
+++ This bug was initially created as a clone of Bug #1279819 +++

Description of problem:

Instruction wizard "Content Host Registration" leaves out steps to attach a subscription and enable repos.

Step 4 says install katello-agent which you 
cannot do as you have no repos at that point.

If you chose to use an activation key:
Step 3 assumes that your activation key provides access
to a subscription & content view (or has auto-attach set to 'True').
Otherwise, there step 4 would not work.

If you chose not to use an activation key:
You still need to attach a subscription and enable some repos.

Version-Release number of selected component (if applicable):
[root@rhel7-1-sat6 ~]# rpm -q katello
katello-2.2.0.16-1.el7sat.noarch
[root@rhel7-1-sat6 ~]# rpm -q foreman
foreman-1.7.2.43-1.el7sat.noarch


How reproducible:
Every time.

Steps to Reproduce:
1. Click Hosts → Content Hosts and then click Register Content Host. 


Actual results:

1. Select a Content Source:
[drop-down list of content sources]

2. Install the pre-built bootstrap RPM:
rpm -Uvh http://capsuleserver.example.com/pub/katello-ca-consumer-latest.noarch.rpm

3. Run subscription-manager in a console on the client host. You may use an Activation Key to register:
subscription-manager register --org="The_Demo_Org" --activationkey="activationkey1"

or authenticate with a username and password:
subscription-manager register --org="The_Demo_Org" --environment="Library"

4. Install katello-agent for remote actions and displaying errata information:
yum -y install katello-agent

Expected results:

1. Select a Content Source:
[drop-down list of content sources]

2. Install the pre-built bootstrap RPM:
rpm -Uvh http://capsuleserver.example.com/pub/katello-ca-consumer-latest.noarch.rpm

3. Run subscription-manager in a console on the client host. You can use an Activation Key to register:
subscription-manager register --org="<The_Demo_Org>" --activationkey="<activationkey1>"

or authenticate with a username and password:
subscription-manager register --org="<The_Demo_Org>" --environment="Library"

4. Attach a subscription:
subscription-manager list --available --all
subscription-manager attach --pool=<pool_ID>

5. Enable repositories:
subscription-manager repos --enable=<repository-to-be-enabled>

6. Install katello-agent for remote actions and displaying errata information:
yum -y install katello-agent


Additional info:

Please do not use "may" as it is sometimes used ambiguously to mean "might" as in "might happen". Use "can" to indicate that something is allowed, can be done.

--- Additional comment from RHEL Product and Program Management on 2015-11-10 07:03:45 EST ---

Since this issue was entered in Red Hat Bugzilla, the pm_ack has been
set to + automatically for the next planned release

--- Additional comment from Stephen Wadeley on 2015-11-10 07:50:59 EST ---

Will clone for the Installation Guide

=======

Procedure 7.6. Registering Host Systems to the Capsule Server[1]

Duplicates the Instruction Wizard which is incorrect (as per parent bug)

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Registering_Host_Systems_to_a_Red_Hat_Satellite_Capsule_Server.html
Comment 10 Andrew Dahms 2017-05-24 19:06:03 EDT
Resetting the QA contact.
Comment 11 Andrew Dahms 2017-06-13 01:46:51 EDT
The content in this bug was included in the Satellite 6.1 version of the Installation Guide, but does not have a home in the 6.2 content after the re-structure.

That said, we do have a customer case bug requesting more information about registering hosts. Therefore, I have added a link to the content that was created in this bug to that bug so that it can be used as a reference, and incorporated.

Closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1446374 ***

Note You need to log in before you can comment on or make changes to this bug.