Bug 127991 - kprinter defaults to LPRng
Summary: kprinter defaults to LPRng
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-16 04:13 UTC by Ian Mortimer
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 10:38:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Mortimer 2004-07-16 04:13:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The default printing system in kprinter is LPRng but Fedora doesn't
even include LPRng any more.  The default should be cups since that is
the only printing system bundled with Fedora.

A workaround is to add this line to the end of
/usr/share/config/kdeprintrc:

PrintSystem=cups


Version-Release number of selected component (if applicable):
kdebase-3.1-15

How reproducible:
Always

Steps to Reproduce:
1. start kprinter
2. observe setting for "print system currently used"
3.
    

Actual Results:  It's set to LPR/LPRng

Expected Results:  It should be set to CUPS

Additional info:

This is easily fixed but is confusing to novices who can't figure out
why printing from kprinter isn't working even though printing is set
up correctly and working from other applications or from the command line.

Comment 1 Ngo Than 2004-07-19 10:38:59 UTC
it's fixed in kdelibs-3.2.3-6. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.