Bug 127993 - USB CD-ROM not picked up
USB CD-ROM not picked up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 00:52 EDT by James Cook
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:20:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Cook 2004-07-16 00:52:52 EDT
With FC3/Test 1, anaconda has forgotten how to deal with my USB CDROM.
 I think it has something to do with the new kernel's ability to
identify the chipset of the USB/IDE bridge and it thinks it's a
harddrive.  What I see on console 4 is:

<6>Initializing USB Mass Storage driver...
<6>scsi3 : SCSI emulation for SB Mass Storage devices
<5>  Vendor: Revoltec  Model: USB/IDE Bridge (  Rev: 0103
<5>  Type:   Direct-Access                      ANSI SCSI revision: 02
<5>SCSI device sdc: 322700 2048-byte hdwr sectors (661 MB)
<5>sdc: Write Protect is off
<7>sdc: Mode Sense: 00 76 11 00
<3>sdc: assuming drive cache: write through
<6> sdc: unknown partition table
<5>Attached scsi removable disk sdc at scsi3, channel 0, id 0, lun 0
<7>USB Mass Storage device found at 4
<6>usbcore: registered new driver usb-storage
<6>USB Mass Storage support registered.
Comment 1 Jeremy Katz 2004-07-16 00:54:58 EDT
Yeah, that's not a cd-rom drive as far as most of the world would be
concerned...
Comment 2 James Cook 2004-07-16 01:50:39 EDT
Some additional info.  It appears that there was a patch applied on
the 29th of last month
http://216.239.39.104/search?q=cache:U0I3P45B278J:www.kernel.org/pub/linux/kernel/v2.6/testing/cset/cset-torsten.scherer%40uni-bielefeld.de%257CChangeSet%257C20040629164624%257C09829.txt+revoltec+ide+usb+linux&hl=en
 that may be the culprit.  The USB/IDE bridge chip that "owns" the IDs
specified in the patch is the ALI M5621.  On the linux USB device
overview (http://www.qbik.ch/usb/devices/showdev.php?id=2645) that
particular bridge is listed as working prior to the patch.

I was able to get FC3 installed by first connecting the USB cable so
that the BIOS could boot off it and then as soon as the kernel took
over, unplugging the USB cable and plugging in a firewire cable.  Not
something that Joe Sixpack will probably want to do.  =)
Comment 3 Dave Jones 2005-07-15 14:16:51 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 James Cook 2005-07-16 15:53:43 EDT
FC4 works properly.

Note You need to log in before you can comment on or make changes to this bug.