Bug 1279940 - Storage volume manager does not update free space
Storage volume manager does not update free space
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 09:33 EST by Martin Kolman
Modified: 2015-12-30 19:55 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-manager-1.3.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 19:55:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kolman 2015-11-10 09:33:33 EST
Description of problem:
The storage volume manager does not update free space - even if a volume is deleted, the free space amount displayed is remains the same, even though manual checking of free space on the machine shows that more free space is now available.

Clicking the refresh button also has no effect.


Version-Release number of selected component (if applicable):
1.2.1-3

How reproducible:
always

Steps to Reproduce:
1. open virt manager
2. right click on a hypervisor
3. select details
4. switch to the "Storage" tab
5. delete a storage volume
6. check free space

Actual results:
Free space remains the same even after the volume has been deleted. Manual check shows the displayed free space in virt manager does not match the actual free space in the volume storage folder.

Expected results:
Free space is up to date and matches the actual free space in the volume storage folder.

Additional info:
I looks like if the free space is checked only once when connecting to the hypervisor and never updated again as disconnecting and connecting back updates the free space displayed to correct value. But even then subsequent delete operations don't influence the value displayed.
Comment 1 Cole Robinson 2015-11-10 17:50:08 EST
Thanks for the report, fixed upstream now:

commit 0bf6124a280dbff9c31ac8e88ecea7e42fd0dc14
Author: Cole Robinson <crobinso@redhat.com>
Date:   Tue Nov 10 17:40:04 2015 -0500

    storage: Fix updating UI when volume deleted (bz 1279940)
Comment 2 Martin Kolman 2015-11-13 03:44:49 EST
(In reply to Cole Robinson from comment #1)
> Thanks for the report, fixed upstream now:
> 
> commit 0bf6124a280dbff9c31ac8e88ecea7e42fd0dc14
> Author: Cole Robinson <crobinso@redhat.com>
> Date:   Tue Nov 10 17:40:04 2015 -0500
> 
>     storage: Fix updating UI when volume deleted (bz 1279940)

Nice! :)
Comment 3 Fedora Update System 2015-11-25 15:09:50 EST
virt-manager-1.3.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7dfc5692ef
Comment 4 Fedora Update System 2015-11-26 18:50:39 EST
virt-manager-1.3.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7dfc5692ef
Comment 5 Fedora Update System 2015-12-06 20:07:56 EST
virt-manager-1.3.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6cf48609ca
Comment 6 Fedora Update System 2015-12-07 23:32:30 EST
virt-manager-1.3.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6cf48609ca
Comment 7 Fedora Update System 2015-12-24 14:03:09 EST
virt-manager-1.3.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-237e1d49a8
Comment 8 Fedora Update System 2015-12-28 19:57:11 EST
virt-manager-1.3.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-237e1d49a8
Comment 9 Fedora Update System 2015-12-30 19:54:40 EST
virt-manager-1.3.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.