Bug 1279960 - node loses public key after reboot
node loses public key after reboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
Unspecified Linux
high Severity high
: ovirt-3.5.6
: 3.5.6
Assigned To: Douglas Schilling Landgraf
Ying Cui
node
: Regression, ZStream
Depends On: 1248372
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 10:31 EST by rhev-integ
Modified: 2016-02-10 14:18 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-3.2.3-28.el7 ovirt-node-3.2.3-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1248372
Environment:
Last Closed: 2015-12-01 15:17:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44184 master MERGED persisting the ssh fingerprint keys Never
oVirt gerrit 44210 ovirt-3.5 MERGED persisting the ssh fingerprint keys Never
oVirt gerrit 44323 master MERGED Providing correct path to fingerprint keyes Never
oVirt gerrit 46177 ovirt-3.5 MERGED Providing correct path to fingerprint keyes Never
oVirt gerrit 48047 master MERGED Waiting for sshd to generate the keys Never
oVirt gerrit 48098 master MERGED semodule: Add rule ro AVC sshd_keygen_t plymouth_exec_t Never
oVirt gerrit 48369 ovirt-3.6 MERGED semodule: Add rule ro AVC sshd_keygen_t plymouth_exec_t Never
oVirt gerrit 48370 ovirt-3.6 MERGED Waiting for sshd to generate the keys Never
oVirt gerrit 48372 ovirt-3.5 MERGED semodule: Add rule ro AVC sshd_keygen_t plymouth_exec_t Never
oVirt gerrit 48373 ovirt-3.5 MERGED Waiting for sshd to generate the keys Never

  None (edit)
Comment 3 Ying Cui 2015-11-16 07:36:02 EST
Verified this bug on the following version

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151112.0.el7ev)

# rpm -qa ovirt-node
ovirt-node-3.2.3-27.el7.noarch

Test steps
1. installed rhevh
2. enable ssh
3. ssh via another host, answer yes to ssh prompt for saving the host udentification
4. reboot the rhevh host
5. ssh again 
6. reboot the rhevh host once more
7. ssh again

Step 5 & 7, the SSH fingerprint is not changed.
Comment 5 errata-xmlrpc 2015-12-01 15:17:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2526.html

Note You need to log in before you can comment on or make changes to this bug.