Bug 127997 - comparison seems borked
comparison seems borked
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Robin Norwood
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
Reported: 2004-07-16 04:33 EDT by Patrick C. F. Ernzer
Modified: 2007-07-31 10:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-01 11:40:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2004-07-16 04:33:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)

Description of problem:
I'm having trouble getting one system to sync to the rpms from another

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. kickstart a system with RH Desktop 3 (bootstraping it to the sat)
2. rename the profile of this system to 'old_machine'
3. kickstart again, naming this one 'machine'
4. log on, rpm -e xsane-gimp, up2date -p
5. go to Sat webpage, compare the package list of 'machine' agains
6. select 'xsane-gimp', trigger a sync to 'old_machine'

Actual Results:  error page telling me:
'Missing Packages ...'

xsane-gimp-0.89-3 is listed, but in the table the column for the
Channel is empty.

Click on xsane-gimp-0.89-3 to verify that it is indeed in the channel

List the systems subscribed to this channel, both 'machine' and
'old_machine' are listed

Expected Results:  sheduling of xsane-gimp for roll out on 'machine'

Additional info:

As this job started Monday, we're still using 3.2.0-12

Also, the following packages were installed by hand because they are
not yet available for RH Desktop 3:

Both systems are subscribed to the following channels:
    *  Red Hat Desktop (v. 3 for x86)
          o Desktop 3 externe Multimedia Packete
          o Interne Packete fuer Desktop 3
          o Red Hat Desktop (v. 3 for x86) Extras
          o Red Hat Developer Suite (for Desktop x86)

Where 'Desktop 3 externe Multimedia Packete' contains mozilla-flash,
mplayer and deps from an external source (but does not contain
anything related to xsane or gimp from what I can see)

And 'Interne Packete fuer Desktop 3' contains some internal packages,
again no relation to xsane or gimp.
Comment 1 Patrick C. F. Ernzer 2004-07-16 04:40:27 EDT
FWIW, when going through 'Systems', 'machine', 'Packages', 'Install
New Packages', select xsane-gimp, confirm. Then run rhn_check on the
machine, package is installed fine.
Comment 2 Patrick C. F. Ernzer 2004-07-16 04:46:43 EDT
One more note, rolling back to a snapshot where xsane-gimp was still
installed works just like expected, so at least we have a work around
for those cases where something gets broken on the machine but it is
mnot yet re-installed.
Comment 3 Patrick C. F. Ernzer 2004-07-16 05:29:42 EDT
updated to the 3.2.0-23, no change.
Comment 5 Todd Warner 2004-09-01 12:06:22 EDT
RHN Sat 3.4?
Comment 6 Patrick C. F. Ernzer 2004-09-02 05:04:07 EDT
no, 3.2. The last time I had access to the Sat in question, we were at
3.2.0-23 and the problem persisted.
Have you been able to reproduce this on 3.2 but not on 3.4?

as you seem to also see the bug (IT #48060); do you see it on 3.4 as well?


Comment 7 Thomas Uebermeier 2004-09-03 05:17:45 EDT
No, the Sat in IT #48060 is still on 3.2, has there been made any 
attempts to fix this in 3.4 ? 
Comment 8 Klaus Wurmstein 2004-09-24 04:52:03 EDT
I successfully updated the SAT to 3.4 today.

But the described comparison-problem still exists...



Comment 9 Robin Norwood 2004-09-27 11:35:48 EDT
upping priority to 'HIGH', but it might still get deferred, as time is
short and the buglist is long... :-(
Comment 10 Robin Norwood 2004-09-29 14:16:14 EDT
I haven't been able to reproduce this bug with the latest code.  I
will try reproducing it with version 3.4.0.
Comment 11 Robin Norwood 2004-09-29 16:02:38 EDT
I can't reproduce this in 3.4.0, either.  Can anyone get me more
information - does this happen with any other packages or base channels?
Do you get the same error syncing to a stored package profile?
Comment 12 Thomas Uebermeier 2004-10-01 09:18:02 EDT
- it happens with all packages (even in custom channels). 
- there is only 1 base channel, therefore no testing with different 
- when syncing to a stored package profile the error does not come up 
What informations do you need for further debugging ? 
Comment 14 Bastien Nocera 2004-10-01 11:40:33 EDT
As the problem has been reported as fixed by the customer, closing.
Thanks Robin for the help.

Note You need to log in before you can comment on or make changes to this bug.