Bug 1279983 - deadlock when removing snapshot of root LV from lvremove failing to mlock() itself into memory
deadlock when removing snapshot of root LV from lvremove failing to mlock() i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: LVM and device-mapper development team
cluster-qe@redhat.com
: Regression, ZStream
Depends On: 1278920
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 11:04 EST by Jan Kurik
Modified: 2015-12-15 08:31 EST (History)
16 users (show)

See Also:
Fixed In Version: lvm2-2.02.118-3.el6_7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278920
Environment:
Last Closed: 2015-12-15 08:31:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2044513 None None None Never

  None (edit)
Description Jan Kurik 2015-11-10 11:04:22 EST
This bug has been copied from bug #1278920 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 5 Roman Bednář 2015-11-24 04:26:14 EST
Marking as verified.


lvremove strace output:


old version: lvm2-2.02.118-3.el6_7.3

...
mlock(0x7fc530929000, 0)                = 0
mlock(0x7fc53092a000, 0)                = 0
mlock(0x7fc530b41000, 0)                = 0
...



new version: lvm2-2.02.118-3.el6_7.4

...
mlock(0x7f0a7a024000, 4096)             = 0
mlock(0x7f0a7a025000, 94208)            = 0
mlock(0x7f0a7a23c000, 4096)             = 0
Comment 9 errata-xmlrpc 2015-12-15 08:31:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2635.html

Note You need to log in before you can comment on or make changes to this bug.