Bug 1280 - Kernel 2.0.36 Problem using Network Configurator PPP through COM2:
Kernel 2.0.36 Problem using Network Configurator PPP through COM2:
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-22 13:10 EST by jimomura
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-29 14:16:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jimomura 1999-02-22 13:10:54 EST
I recently posted messages to the "linux.setup" newsgroup
but I have had no helpful responses.  This may be a problem
in the Kernel itself or perhaps in the RPM files, or
related "SysVinit" or "initscripts" files:

---
In a couple of previous messages I reported I was having
problems
using an external Modem on COM2 when I upgraded to Kernel
version
2.0.36-1.  I've continued to work on the problem without
success.

I downloaded the latest Kernel version 2.0.36-3 files.  I
installed
them with "rpm -Uvh --force".  The same COM2 problem showed
up.
I then checked "initscripts" and "SysVinit" and found that I
already
had the latest 5.1 versions (SysVinit 2.74-4 and initscripts
3.67-1).
I tried to install the 5.2 versions ("SysVinit 2.74-5" and
"initscripts-3.78-1") using

rpm -Uvh --force

but the result was:

failed dependencies:
       redhat-release <= 5.1 conflicts with initscripts-
3.78-1

Since the installation failed, I did not re-install 2.0.35-2
--
it should be intact.  Any suggestions would be welcome.


---
Earlier Message:

I've been reading Mark Bratcher's problems regarding RH
Linux 5.2
and his internal COM2 modem and I think there may be a more
general
problem with the 2.0.36 Kernel.

I'm running a Gigabyte 5486AL motherboard (486DX4/100).  I
have a
mouse on COM1 and my external modem on COM2.  I started out
with RH
Linux 5.1 which comes with Kernel version 2.0.35-1 and I've
been
using it as a remote client to my ISP through "Network
Configurator"
PPP through /dev/modem on COM2.  I've been stepping my way
through
upgrades one at a time, so I previously upgraded to Kernel
version
2.0.35-2 without problems.  However, yesterday I tried
upgrading
to Kernel version 2.0.36-1 and I could no longer dial out.
When
you click on "activate" the modem DTR light would come on
for a
moment and then turn off.  It was on for about a 1/4 second.
I
checked the "Network Configurator" settings and everything
seemed
to be ok.  I tried "a few other things" but nothing seemed
to
help.  So I eventually reloaded Kernel version 2.0.35-2 and
it's
working again.

Does anybody have an suggestions for setting changes?  Does
anybody
know of any other problems on the serial ports?

The following is some further information:

Last upgrades just before the Kernel upgrades:

Upgraded "pam" to "pam-0.64-4.i386.rpm" version
Upgraded "ftp" to "ftp-0.10-4.i386.rpm" version

Things I noticed while running with Kernel version 2.0.36-1:

1.  I think I saw some references to 2.0.35 stuff during the
system
boot.  This is hard to tell since some of the boot messages
go by
pretty fast for human eye reading on a DX4/100.  Is there a
way to
store this as a text file?  Is it already being stored
somewhere?

2.  After 2.0.36-1 upgrade, the "finding module
dependencies" during
system boot was still looking for 2.0.35-2 dependencies.
This
is definite.

3.  Also, system boot page still refers to 2.0.35 kernel.
This
latter is probably not relevant since it's probably just a
text file
somewhere that's printed to the tty before the login.

Reinstalling Kernel version 2.0.35-2:

The following errors were returned by rpm:

"cannot remove /lib/modules/2.0.36-1/misc - directory not
empty"
"cannot remove /lib/modules/2.0.36-1 - directory not empty"
"cannot remove /usr/src/linux-2.0.36 - directory not empty"
"package /usr/src/linux-2.0.36/drivers/block/ali4xx.c not
found in
file index"

---
I also tried addressing "/dev/ttyS1" instead of "/dev/modem"
through
"Network Configurator".  That made no difference.  However,
Minicom
had no problem using the COM2: port.
Comment 1 jimomura 1999-06-21 16:17:59 EDT
Last week I upgraded to RHL 6.0.  The complete upgrade had
no problem using the Network Configurator PPP through /dev/modem.
I think that if I'd done a full system upgrade to 5.2, that would
have fixed it too.

     A similar problem is now occurring after upgrading RHL 6.0
from the supplied 2.2.5-15 Kernel to the 2.2.5-22 Kernel, but
I'll submit a new bug report for that one separately.

     Note that the "finding module dependencies" problem also
did not occur after the full upgrade to RHL 6.0

Note You need to log in before you can comment on or make changes to this bug.