Bug 1280013 - Non-python data files missing from test package
Non-python data files missing from test package
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: z3
: 7.0 (Kilo)
Assigned To: Brent Eagles
Toni Freger
: Triaged, ZStream
Depends On:
Blocks: 1281831
  Show dependency treegraph
 
Reported: 2015-11-10 12:50 EST by Brent Eagles
Modified: 2016-04-26 16:21 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1281831 (view as bug list)
Environment:
Last Closed: 2015-12-21 12:00:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249748 None None None Never

  None (edit)
Description Brent Eagles 2015-11-10 12:50:16 EST
python-neutron-tests is missing the contents of neutron/tests/etc. Tests for subprojects such as VPNaaS depend on these files so they need to be included.

How reproducible:
Every time

Steps to Reproduce:
1. install python-neutron-tests
2. try running vpnaas tests in the current environment (site-packages or without a virtual env)

Actual results:

Tests will fail when trying to load neutron.conf.test, etc.


Expected results:

Tests pass, or at least fail for other reasons.
Comment 2 Brent Eagles 2015-11-10 14:32:33 EST
Setting priorities and severity because while the issue probably doesn't affect neutron core users, it does impact testing of subproject packages.
Comment 6 Alan Pevec 2015-11-12 08:54:20 EST
Please fix this in rpm-master first.
Comment 7 Brent Eagles 2015-11-12 13:27:41 EST
Alan - thanks for the reminder. In this case I think I'm safe since the fix was actually a cherry picked commit from https://review.gerrithub.io/#/c/249748 - so it should be fixed in rpm-master already.
Comment 9 Toni Freger 2015-11-23 08:03:12 EST
Verified on AIO openstack-neutron-2015.1.2-2.el7ost.noarch
Rhel7.2


All required files are exist under:
/usr/lib/python2.7/site-packages/neutron/tests/etc
#ls -la
4 -rw-r--r-- 1 root root  290 Oct 13 20:35 api-paste.ini.test
4 -rw-r--r-- 1 root root  550 Oct 13 20:35 neutron.conf.test
8 -rw-r--r-- 1 root root 7576 Oct 13 20:35 policy.json
Comment 11 errata-xmlrpc 2015-12-21 12:00:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2652

Note You need to log in before you can comment on or make changes to this bug.