Bug 128002 - httpd startup fails with LANG=tr_TR.UTF-8
httpd startup fails with LANG=tr_TR.UTF-8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
http://nagoya.apache.org/bugzilla/sho...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 06:29 EDT by Onur Gungor
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.50-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 03:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Onur Gungor 2004-07-16 06:29:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When I try to start the httpd daemon with the predefined settings, it
'seems' to work, but if I check it with /etc/init.d/httpd status it
gives me this message: (in fact its Turkish version but I guessed the
English one)

httpd is dead but subsys is locked

I have found a workaround for this:

I comment out the 423, 425 and 426th lines in
/etc/httpd/conf/httpd.conf file, the ones about mod_mime_magic.c .

423: <IfModule mod_mime_magic.c>
424: #   MIMEMagicFile /usr/share/magic.mime
425:    MIMEMagicFile conf/magic
426: </IfModule>


I didn't further investigate whether this is with the inexistence of
mod_mime_magic or some other configuration fallacy.

Version-Release number of selected component (if applicable):
httpd-2.0.49-4

How reproducible:
Always

Steps to Reproduce:
1. Make sure that httpd package is installed. (from fc2 rpms)
2. try to start the daemon.
3. check that it is not responding.

Actual Results:  When I check the status of the daemon what I get is:
httpd is dead but subsys is locked

Expected Results:  httpd running pids or something.

Additional info:
Comment 1 Joe Orton 2004-07-16 06:31:59 EDT
Are there error messages in /var/log/httpd/error_log?
Comment 2 Onur Gungor 2004-07-16 06:55:28 EDT
Nothing unusual. Here are the excerpts when I start the daemon:

[Fri Jul 16 13:53:03 2004] [debug] util_ldap.c(1129): LDAP cache:
Unable to init Shared Cache: no file
[Fri Jul 16 13:53:03 2004] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Fri Jul 16 13:53:03 2004] [notice] LDAP: SSL support unavailable
[Fri Jul 16 13:53:03 2004] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Fri Jul 16 13:53:03 2004] [info] Init: Initializing OpenSSL library
[Fri Jul 16 13:53:03 2004] [info] Init: Seeding PRNG with 256 bytes of
entropy
[Fri Jul 16 13:53:03 2004] [info] Init: Generating temporary RSA
private keys (512/1024 bits)
[Fri Jul 16 13:53:03 2004] [info] Init: Generating temporary DH
parameters (512/1024 bits)
[Fri Jul 16 13:53:03 2004] [info] Init: Initializing (virtual) servers
for SSL
[Fri Jul 16 13:53:03 2004] [info] Server: Apache/2.0.49, Interface:
mod_ssl/2.0.49, Library: OpenSSL/0.9.7a
Comment 3 Joe Orton 2004-07-16 07:05:43 EDT
Ah, this is the problem due to the Turkish locale causing strcasecmp()
to not match directive names case-insensitively.

echo LANG=en_US >> /etc/sysconfig/httpd

is a workaround.
Comment 4 Joe Orton 2004-07-16 07:08:30 EDT
Adding reference to upstream bug.
Comment 5 Joe Orton 2004-08-24 03:50:03 EDT
Since the fix for this issue is a behaviour change, and has a simple
workaround, integration will be delayed until the next release.

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.